ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか? Vol.1479

カテゴリー: 2018年07月06日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
日本語で勉強できる!CCIE Routing & Switching 実践ワークブック
      http://www.n-study.com/library-new/ccie-rs-workbook/

CCIEに合格するために、何をやったらいいかわからない困っている方は、

     「このワークブックを隅から隅までやってください」

とオススメします。繰り返しラボを実践すると、CCIE合格レベルの実力が身に
つくでしょう。

ワークブック ラボ02 Troubleshootingの一部の動画解説です。
https://www.youtube.com/watch?v=KrtbctKgzUI
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2018/7/5 Vol.1479 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆OSPFの基本設定
	◆Youtube Gene Channel 技術解説動画
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
  MPLS-VPNトラブルシュートシナリオ Vol.1
  http://www.n-study.com/library-new/mpls-vpn-lab/
  MPLS-VPN演習シナリオ Vol.1
  http://www.n-study.com/library-new/mpls-vpn-troubleshooting/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
※CCIEv5では、MPLS-VPNはとても重要です。MPLS-VPNの仕組みを理解して、Cisco
  での設定と確認をする手順を学ぶための役に立てるコンテンツです!

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」


こんにちは、発行者のGene(じーん)です。

今回はCiscoルータでのOSPFの基本設定です。OSPFの動作の仕組みは難しいイ
メージがあるかもしれませんが、設定自体はとても簡単です。OSPFを有効にす
るインタフェースを決めるだけでいいです。ルーティングテーブルに登録され
るルート情報がどんなものなのかを知らなくても設定はできてしまいます。
これはOSPFに限らずRIPやEIGRPでも同じです。ルーティングプロトコルの設定
は簡単なんです。


└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐

  
  「OSPFの基本設定」


~設定手順~

OSPFの基本的な設定手順は、次の2つです。

1.OSPFルーティングプロセスの起動
2.インタフェースでOSPFを有効化


OSPFルーティングプロセスを起動するには、グローバルコンフィグレーション
モードで次のコマンドを入力します。

(config)#router ospf <process-id>
(config-router)#

<process-id> : OSPFプロセス番号

プロセス番号は1~65535の任意の番号を指定します。1台のルータで複数のOSPF
プロセスを起動することもでき、プロセス番号はルータローカルでOSPFプロセ
スを識別するためのものです。ただし、特別な理由がない限り、複数のOSPFプ
ロセスを起動することはありません。ルータローカルで利用するので、他のル
ータと合わせる必要はありません。ただし、ルータごとにバラバラなプロセス
番号だと設定がわかりづらくなるので、同じプロセス番号を利用することが一
般的です。
そして、インタフェースでOSPFを有効化するには2通りの設定があります。以
前より利用している設定はOSPFのコンフィグレーションモードでの設定です。

(config-router)#network <ip-address> <wildcardmask> area <area-id>

<ip-address> : IPアドレス
<wildcardmask> : ワイルドカードマスク
<area-id> : エリア番号

<ip-address> <wildcardmask>の組み合わせで、OSPFを有効化したいインタフェー
スに設定されているIPアドレスのビットパターンを指定します。たとえば、
「192.168.0.0 0.0.255.255」であれば、先頭16ビットが「192.168」のIPア
ドレスのインタフェースという意味です。インタフェースでOSPFを有効化す
るのですが、設定上はインタフェース名ではなく「インタフェースに設定さ
れているIPアドレスのビットパターン」を指定することになります。そして、
OSPFを有効化したインタフェースが所属するエリア番号を指定します。
もう1つの設定方法は、OSPFを有効にしたいインタフェースのインタフェース
コンフィグレーションモードの設定です。

(config-if)#ip ospf <process-id> area <area-id>

<process-id> : OSPFプロセス番号
<area-id> : エリア番号

どちらの設定方法にせよ、「インタフェースでOSPFを有効にする」ということ
をしっかりと意識してください。OSPFコンフィグレーションモードの設定とイ
ンタフェースコンフィグレーションモードの設定が重複している場合は、イン
タフェースコンフィグレーションモードの設定のほうが優先されます。
マルチエリアでABRとして設定する場合は、エリア0のインタフェースとそれ以
外のエリアのインタフェースの設定を行えばよいだけです。ABRとするための
特別なコマンドはありません。


~OSPFの設定例~

以下は、シンプルなネットワーク構成でのOSPFの設定例です。


http://www.n-study.com/wp-content/uploads/2018/07/ospf_config01.png
図 OSPF設定例


R1(ABR)
------------------------
router ospf 1
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.13.1 0.0.0.0 area 1
------------------------

R2
------------------------
interface Ethernet 0/0
 ip ospf 1 area 0
!
interface Ethernet 0/1
 ip ospf 1 area 0
!
router ospf 1
------------------------

R3
------------------------
router ospf 1
 network 192.168.0.0 0.0.255.255 area 1
------------------------

R1はABRです。E0/0をエリア0のインタフェースとし、S1/0をエリア1のインタ
フェースとしています。R2はインタフェースコンフィグレーションモードでの
OSPF有効化の設定例です。そして、R3ではワイルドカードマスクの指定で、
E0/1とS1/0の2つのインタフェースを1行のnetworkコマンドで有効化している
例です。
OSPFプロセス番号はすべて共通で1としています。これは設定をわかりやすく
するためで、プロセス番号は一致していなくても問題ありません。


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
17年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐

  「Youtube Gene Channel 技術解説動画」


これまで有料版のPREMIUMで月に1回動画解説を配信しています。もうかれこれ
5年以上続けているので、60個ぐらいあります。
PREMIUM用の動画解説に加えて、ちょこちょこ動画解説を作っていくことにし
ました。主にCiscoルータでの設定と検証の様子を解説しています。


--------------------------------------------------------------
IPSec DMVPN(NHRP Phase1) 
https://www.youtube.com/watch?v=kopwQcYe13Y

Ciscoルータを使ったIPSecのDMVPNの設定と検証の様子です。NHRP Phase1でハ
ブ&スポーク構成の部分を公開しています。NHRP Phase2およびNHRP Phase3の
設定については、「ネットワークのおべんきょしませんか? PREMIUM」の2015
年8月分の動画解説コンテンツです。
--------------------------------------------------------------
不連続サブネットにおけるEIGRPの設定
https://www.youtube.com/watch?v=KDwK3EGmExU

不連続サブネットでのEIGRPの設定についての注意点です。自動集約が有効に
なって-いると、ルーティングテーブルに正しくルートが登録されなくなって
しまいます。
CCNAでよく問題が出てきますね。自動集約が有効なときと無効なときのルート
のアド-バタイズ、そして、ルーティングテーブル上のルートがどのようにな
っているかを見てく-ださい。
--------------------------------------------------------------
MPLS VPNのトラブル その1 
https://www.youtube.com/watch?v=-ygnvEIyPHw

MPLS-VPNのトラブルシュートの例です。

動画で解説している内容は、以下のWebページに載せています。
http://www.n-study.com/network/2010/0...
--------------------------------------------------------------
MPLS-VPNのさまざまな接続性 フルメッシュ(Any-to-Any) 
https://www.youtube.com/watch?v=BAldXCPQnHM

CiscoルータでのMPLS-VPNの設定例です。最も基本的な拠点間のフルメッシュ
の接続性についてです。
ここで解説している内容は、以下のWebページにまとめています。

MPLS-VPNのさまざまな接続性 フルメッシュ(Any-to-Any)
http://www.n-study.com/network/2014/08/mplsvpn_anytoany.html

※有料メールマガジン「ネットワークのおべんきょしませんか? PREMIUM
(http://www.mag2.com/m/P0000264.html)」の2014年8月のバックナンバーを購
入していただくと、フルメッシュだけではなくエクストラネット、セントラル
サービス、ハブ&スポーク構成のすべての動画解説をダウンロードしていただ
けます。
--------------------------------------------------------------
日本語で勉強できる!CCIE R&S ワークブック ラボ#02 Troubleshoot サンプル TT01
https://www.youtube.com/watch?v=KrtbctKgzUI

日本語で勉強できる!CCIE R&S ワークブック ラボ#02 Troubleshoot サンプ
ルです。TroubleTicket01についての動画解説です。TroubleTicket01は、基本
的なPPPリンクの設定ミスです。レイヤ2レベルの切り分けができないと、その
あと、まるごとできなくなってしまうので、レイヤ2レベルのトラブルシュー
トは、とても重要です。

以下のWebページに動画で解説している内容を掲載しています。
http://www.n-study.com/network/2015/04/ccie_rs_02_troubleshoot.html

日本語で勉強できる!CCIE R&S ワークブック
http://www.n-study.com/library/2015/04/ccie_rs.html
--------------------------------------------------------------
Anycast RP with MSDP
https://www.youtube.com/watch?v=KVsy6oz-UWI
マルチキャストルーティングのRPの冗長化と負荷分散を行うAnycast RP with MSDP
の設定についてです。
解説しているStepは、以下のURLに載せています。

http://www.n-study.com/network/2009/02/anycast_rp_3.html
http://www.n-study.com/network/2009/02/anycast_rp_4.html
--------------------------------------------------------------
PIM SM Basic Configuration Static RP
https://www.youtube.com/watch?v=LnvjbAsX44o
PIM-SMの基本設定でのスタティックRPの設定の様子をステップバイステップで
解説しています。

この動画は以下のURLのWebページの内容についての解説です。
PIM-SMの設定演習 [スタティックRP]
http://www.n-study.com/network/2015/02/pimsm_rp.html

RPの設定だけではなく、同一セグメントに複数のPIMルータがいる場合はDRに
よってマルチキャストパケットの転送経路が決まることも重要なポイントです。
スタティックRP以外の設定の様子は、有料版メールマガジン「ネットワークの
おべんきょしませんか? PREMIUM」の2015年3月の動画解説コンテンツです。
--------------------------------------------------------------
BGPの基本的な設定 トラブルシュート
https://www.youtube.com/watch?v=8yDXXD7yotw
BGPの設定ミスを切り分けるトラブルシュートの簡単な解説です。
設定ミスのないBGPのネットワーク構成は、以下のURLで解説しています。

BGPの基本的な設定
http://www.n-study.com/network/2015/01/bgp_9.html

この動画は、以下のURLに基づいた解説です。
BGPの基本的な設定 トラブルシュート
http://www.n-study.com/network/2015/02/bgp_10.html

CCIEv5では、トラブルシュートセクションについてかなり敷居が高く感じる方
が多いようです。決して技術的には難しくありませんが、トポロジを構成する
台数が多いため難しい印象があるようです。CCIEを受験される方は、このぐら
いの切り分けと修復がさくさくできるレベルを目指しましょう。
--------------------------------------------------------------
VRFとtunnelインタフェース(GRE over IPSec) 
https://www.youtube.com/watch?v=LmijJlJ3qsg

VRF LiteでGRE over IPSecを構成する場合の設定例について、設定と確認の様
子をステップバイステップで解説しています。
CCIEv5 Routing & Switchingラボ試験でとても重要です。

この動画での解説の内容は、以下のWebページにあります。
http://www.n-study.com/network/2014/12/vrftunnelgre_over_ipsec.html
--------------------------------------------------------------


└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

さよならXperia。
こないだの日曜日にふと気がつくとスマホの画面が浮き上がっていました。ど
うやらバッテリーパックが膨張してしまっているようです。

10月に更新のタイミングで、そのときに新しくしようと思っていたのですが、
画面が浮き上がっている状態ではとても使えないので、もう、新しいスマホに
変えてしまいました。

5年ほどXperiaを使っていて、今度もXperia XZ2 Premiumにしようと思ってい
たんですが、まだPremiumは出ていない・・・同じスナドラ845で6GBのメモリ
を積んでいるGalaxy S9+にしました。XZ2PよりもGalaxyのほうがデザインも
スマートで軽いので、迷っていたんですよね。
また、2年できっとXperiaに戻ります。それまでXperia続けていてね。

そして、テザリングを有料にしたauが気に入らなかったので、docomoにかえま
した。テザリングなんか基本の通信サービスという認識です。しょうもないク
ーポンを配ったり、当たりもしないクジを引かせるよりも通信サービスをきち
んとしろよ。更新月じゃないので解約料とられたんですけど、もう変えてしま
いました。


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2016 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/02/15 部数:  10,646部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/02/15 部数:  10,646部

他のメルマガを読む