ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1298 BGPの基本的な設定 トラブルシュート

カテゴリー: 2015年02月13日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
新CCNA試験に対応!
「Cisco試験対策 Cisco CCNA Routing and Switching/CCENT問題集」
  www.amazon.co.jp/exec/obidos/ASIN/4797374918/networkstudy-22/ref=nosim/
  Amazon Kindle版も配信されました!!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2015/2/13 Vol.1298 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆BGPの基本的な設定 トラブルシュート
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」


こんにちは、発行者のGene(じーん)です。

BGPの基本設定についてのトラブルシュートの切り分けと設定の修復です。あ
まり細かく解説はしていませんが、これまで繰り返し述べているように、適切
なshowコマンドを使いこなしていくことがとても重要です。


※これまで有料版のPREMIUMで月に1回動画解説を配信しています。もうかれこ
  れ5年以上続けているので、60個ぐらいあります。
  PREMIUM用の動画解説に加えて、ちょこちょこ動画解説を作っていくことに
  しました。
  主にCiscoルータでの設定と検証の様子を解説しています。
  
  以下のWebページの内容の動画解説です。
  http://www.n-study.com/network/2014/12/vrftunnelgre_over_ipsec.html
  VRFとtunnelインタフェース(GRE over IPSec) 
  https://www.youtube.com/watch?v=LmijJlJ3qsg

  月に2つずつぐらいYoutubeで公開していこうと考えています。それとPREMIUM
  用を併せて、動画解説を3つずつぐらい作っていきます。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
  MPLS-VPNトラブルシュートシナリオ Vol.1
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
  MPLS-VPN演習シナリオ Vol.1
  http://www.n-study.com/library/2012/05/ccie_mplsvpn_vol1_1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
※CCIEv5では、MPLS-VPNはとても重要です。MPLS-VPNの仕組みを理解して、Cisco
  での設定と確認をする手順を学ぶための役に立てるコンテンツです!

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「BGPの基本的な設定 トラブルシュート 切り分けと修復」

~設定ミスの内容と修正~

【1】
R1でR4のLoopback1に対するスタティックルートの設定でネクストホップアド
レスが正しくありません。そのため、EBGPネイバーを確立できません。


切り分け
R1
----------------------------------------------------
R1#show ip bgp summary
BGP router identifier 192.168.0.1, local AS number 65001
BGP table version is 2, main routing table version 2
1 network entries using 117 bytes of memory
1 path entries using 52 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 417 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.1.4        4 65002       0       0        0    0    0 never    Active
192.168.0.2     4 65001       4       4        2    0    0 00:01:27        0
192.168.0.3     4 65001       5       4        2    0    0 00:01:50        1
R1#show ip route static
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
S       10.1.1.4/32 [1/0] via 10.1.41.40
                    [1/0] via 10.1.14.40
----------------------------------------------------


設定の修正

R1
----------------------------------------------------
ip route 10.1.1.4 255.255.255.255 10.1.14.4
ip route 10.1.1.4 255.255.255.255 10.1.41.4
no ip route 10.1.1.4 255.255.255.255 10.1.14.40
no ip route 10.1.1.4 255.255.255.255 10.1.41.40
----------------------------------------------------


【2】
R2でEBGPネイバーのR5のIPアドレスを間違えて指定しています。そのため、R2
とR5間のEBGPネイバーを正しく確立できません。


切り分け

R2
---------------------------------
R2#show ip bgp summary
BGP router identifier 192.168.0.2, local AS number 65001
BGP table version is 2, main routing table version 2
1 network entries using 117 bytes of memory
1 path entries using 52 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 417 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.2.52.5       4 65002       0       0        0    0    0 never    Idle
192.168.0.1     4 65001       5       5        2    0    0 00:02:29        0
192.168.0.3     4 65001       6       5        2    0    0 00:02:51        1
---------------------------------


設定の修正

R2
---------------------------------
router bgp 65001
 no neighbor 10.2.52.5 remote-as 65002
neighbor 10.2.25.5 remote-as 65002
---------------------------------


【3】
R4でIBGPネイバーのR6のAS番号の指定を間違えています。そのため、R4とR6間
でIBGPネイバーを正しく確立できません。


切り分け

R4
---------------------------------
R4#show ip bgp summary
BGP router identifier 192.168.0.4, local AS number 65002
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.1.1        4 65001       0       0        0    0    0 never    Active
192.168.0.5     4 65002       6       6        1    0    0 00:03:55        0
192.168.0.6     4 65001       0       0        0    0    0 never    Idle
---------------------------------


設定の修正

R4
---------------------------------
router bgp 65002
 no neighbor 192.168.0.6 remote-as 65001
 neighbor 192.168.0.6 remote-as 65002
 neighbor 192.168.0.6 update-source Loopback0
 neighbor 192.168.0.6 next-hop-self
---------------------------------


【4】
R3のE0/1でのOSPFコストの設定が抜けています。そのため、R3での100.2.2.0/24
のベストパスはルータIDによってR1から受信したルートが選ばれています。


切り分け

R3
---------------------------------
R3#show ip bgp 100.2.2.0
BGP routing table entry for 100.2.2.0/24, version 4
Paths: (2 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  65002
    192.168.0.1 (metric 11) from 192.168.0.1 (192.168.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
  65002
    192.168.0.2 (metric 11) from 192.168.0.2 (192.168.0.2)
      Origin IGP, metric 0, localpref 100, valid, internal
---------------------------------


設定の修正

R3
---------------------------------
interface Ethernet0/1
 ip ospf cost 1
---------------------------------


【5】
R6のmaximum-pathsの対象がEBGPルートとなっています。そのため、100.1.1.0/24
に対する負荷分散ができません。


切り分け

R6
---------------------------------
R6#show ip protocols
Routing Protocol is "ospf 1"
~省略~

Routing Protocol is "bgp 65002"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Neighbor(s):
    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
    192.168.0.4
    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
    192.168.0.5
  Maximum path: 2
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.4          200      00:02:39
    192.168.0.5          200      00:03:01
  Distance: external 20 internal 200 local 200

---------------------------------


設定の修正

R6
---------------------------------
router bgp 65002
 maximum-paths ibgp 2
 no maximum-paths 2
---------------------------------



└─────────────────────────ALL_@bout_Network─┘


┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

いまちょこちょことWordPressをいじっています。5~6年前にもすこし触って
みたことがあったんですが、ずいぶんと進化しましたね。ウチのWebサイトを
今度WordPressで再構築しようと思っています。


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2015 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,622部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,622部

他のメルマガを読む