ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1181 IPv6での再配送の注意 その1

カテゴリー: 2012年10月24日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

【サーバー運用保守サービス】 東京・神奈川・千葉・埼玉対応可能。

サーバー運用や構築・監視など、サーバー・ネットワーク関連全般を経験豊富
な上級エンジニアが支援・代行します。緊急対応も可能。他社からの移行、前
任者からの引継ぎ、システム開発者との連携なども柔軟に対応可能です。

無料相談受付中。先着3社まで初期診断無料⇒ http://tinyurl.com/d3mok2y

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
サーバー・ネットワーク運用は、今や会社にとって肝!いざという時のために
日頃から信頼出来るサーバー保守会社をお勧めします。(Gene)


┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2012/10/24 Vol.1181 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆IPv6での再配送の注意 その1
	◆Geneが講師を担当するセミナー情報
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん)です。

今回と次回でIPv6での再配送の設定のときの注意点をお届けします。ほとんど
IPv4のときと考え方は同じなんですが、境界ルータのConnectedのネットワー
クの扱いがちょっと違っています。

まずは、IPv4のときの再配送についての振り返りです。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCNP ROUTE セフルスタディキット
Geneが「CCNP ROUTEテキスト」の内容をすべて解説した講義形式のEラーニング
http://www.it-square.co.jp/shopdetail/008000000013/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「IPv6での再配送の注意 その1」


~IPv6での再配送~

IPv6でも複数のルーティングプロトコルを利用している場合、ルーティングプ
ロトコルの境界のルータで再配送の設定が必要です。基本的な考え方はIPv4の
ときと同じで、設定コマンドもほとんど同じです。しかし、IPv6での再配送は
IPv4のときと動作が少し異なるところがあり、注意が必要です。

それは、

「境界ルータのConnectedのプレフィクスは再配送されない」

ということです。

IPv4では、境界ルータのConnectedのネットワークアドレスは自動的に再配送
されていますが、IPv6では明示的にオプションを指定しないと再配送されない
ことに要注意です。
簡単なネットワーク構成にで、IPv4とIPv6でのこうした再配送時の動作の違い
を確認しましょう。


~ネットワーク構成~

次のネットワーク構成でIPv4とIPv6での再配送の違いを見ていきます。
R1-R2間はOSPFで、R2-R3間はRIPを利用します。OSPFとRIPの境界となるR2で双
方向の再配送を行います。


http://www.n-study.com/network/image/ipv6_redistribute01.html
図 IPv4/IPv6再配送 ネットワーク構成


~初期設定~

R1~R3の初期設定は、インタフェースにIPv4/IPv6アドレスを設定しているだ
けです。各ルータの初期設定の抜粋は次のようになっています。

R1
--------------------------------------------------
ipv6 unicast-routing
!
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
 ipv6 address 2001:192:168:1::1/64
!
interface Ethernet0/1
 ip address 192.168.12.1 255.255.255.0
 ipv6 address 2001:192:168:12::1/64
--------------------------------------------------

R2
--------------------------------------------------
ipv6 unicast-routing
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
 ipv6 address 2001:192:168:12::2/64
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
 ipv6 address 2001:192:168:23::2/64
--------------------------------------------------

R3
--------------------------------------------------
ipv6 unicast-routing
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
 ipv6 address 2001:192:168:23::3/64
!
interface Ethernet0/1
 ip address 192.168.3.3 255.255.255.0
 ipv6 address 2001:192:168:3::3/64
--------------------------------------------------


~IPv4の再配送の設定~
【Step1:OSPFの設定】
R1、R2でOSPFを有効化します。OSPFルータIDはX.X.X.X(X=ルータ番号)として
、エリアはすべて0とします。

R1
--------------------------------------------------
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
--------------------------------------------------

R2
--------------------------------------------------
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 0
--------------------------------------------------

【Step2:RIPv2の設定】
R2、R3でRIPv2を有効化します。

R2
--------------------------------------------------
router rip
 version 2
 network 192.168.23.0
--------------------------------------------------

R3
--------------------------------------------------
router rip
 version 2
 network 192.168.3.0
 network 192.168.23.0
--------------------------------------------------


【Step3:ルーティングテーブルの確認】
この時点で境界のR2でのルーティングテーブルは以下のようになります。

R2
--------------------------------------------------
R2#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.23.0/24 is directly connected, Ethernet0/1
O    192.168.1.0/24 [110/20] via 192.168.12.1, 00:17:02, Ethernet0/0
R    192.168.3.0/24 [120/1] via 192.168.23.3, 00:00:01, Ethernet0/1
--------------------------------------------------

R2だけがネットワーク構成での必要なルート情報をRIP、OSPFで学習できてい
ます。しかし、R1はRIPドメインの192.168.23.0/24、192.168.3.0/24のルート
情報を学習できません。また、R3はOSPFドメインの192.168.12.0/24、192.168.1.0/24
のルート情報を学習できません。


【Step4:OSPF、RIPの双方向再配送の設定】
R1、R3で必要なルート情報をルーティングテーブルに学習できるように、R2で
OSPFとRIPの双方向の再配送を設定します。
OSPFへの再配送では必ずsubnetsのオプションが必要です。また、RIPへの再配
送ではシードメトリックの指定が必要です。

R2
--------------------------------------------------
router ospf 1
 redistribute rip subnets
!
router rip
 redistribute ospf 1 metric 3
--------------------------------------------------


【Step5:再配送の確認】
R2でのOSPFとRIPの双方向再配送を確認します。RIPからOSPFへの再配送が正常
に行われていることをshow ip ospf databaseコマンドで確認します。

R2
--------------------------------------------------
R2#show ip ospf database 

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         70          0x80000004 0x004F5D 2
2.2.2.2         2.2.2.2         2           0x80000004 0x00E93C 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.2    2.2.2.2         2           0x80000002 0x008D20

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.3.0     2.2.2.2         150         0x80000001 0x00D853 0
192.168.23.0    2.2.2.2         150         0x80000001 0x00FB1C 0
--------------------------------------------------

LSAタイプ5でRIPドメインの192.168.3.0/24と192.168.23.0/24のルートが生成
されていることがわかります。ここでのポイントは、R2のConnectedの192.168.23.0/24
のルートもOSPFへ再配送されていることです。
そして、OSPFからRIPへの再配送が正常に行われていることをshow ip rip database
コマンドで確認します。

R2
--------------------------------------------------
R2#show ip rip database 
192.168.1.0/24    auto-summary
192.168.1.0/24    redistributed
    [3] via 192.168.12.1, from 1.1.1.1, 
192.168.3.0/24    auto-summary
192.168.3.0/24
    [1] via 192.168.23.3, 00:00:19, Ethernet0/1
192.168.12.0/24    auto-summary
192.168.12.0/24    redistributed
    [3] via 0.0.0.0, 
192.168.23.0/24    auto-summary
192.168.23.0/24    directly connected, Ethernet0/1
--------------------------------------------------

OSPFドメインの192.168.12.0/24と192.168.1.0/24のルートがRIPドメインに再
配送されていることがわかります。やはり、R2のConnectedの192.168.12.0/24
のルートが再配送の対象となっています。

このように境界ルータのConnectedのネットワークアドレス(192.168.12.0/24、
192.168.23.0/24)も再配送の対象となっているのがIPv4での再配送時の動作です。


http://www.n-study.com/network/image/ipv6_redistribute02.html
図 IPv4での再配送の動作


【Step6:通信確認】
R2でOSPFとRIPの双方向再配送を行うことで、OSPFドメインとRIPドメイン間の
通信ができます。R1でPingによって確認すると、次のようになります。

R1
--------------------------------------------------
R1#ping 192.168.3.3 source 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/40 ms
R1#ping 192.168.3.3                   

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/20 ms
--------------------------------------------------

R1で送信元IPアドレスを192.168.1.1にした場合でも、192.168.12.1にした場
合でもRIPドメインの192.168.3.3あてのPingが成功していることがわかります。


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
12年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。



「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html
Geneが講師を担当するネットワークの基礎セミナーです。インターネットの設
定や通信の仕組みを4時間で学べます。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
2012/11/06(火) ・11/13(火) 
ネットワーク構成図を読み解く力を鍛えるセミナー
              「高可用性ネットワークの構築」
http://www.pasonatech.co.jp/event/index.jsp?mode=2&d=on&no=3597

ネットワークを通じて提供するサービスは、常に使えることが求められます。
そのためには、可用性が高く確保された「止めない」ネットワークを構築
しなければいけません。そしてその「止めない」ネットワークを構築する
ためには、さまざまなプロトコルを組み合わせなければいけません。
本セミナーでは、「止めない」ネットワークを構築するために
スパニングツリー、ルーティングプロトコル、VRRPの仕組みを復習します。
そして、問題演習を通じて止めないネットワークを構築するためのポイントを
学んでいただきます。

※本セミナーは、技術解説編と演習編の2回構成です。
 1回目(11/06):技術解説
 2回目(11/13):技術解説を元にネットワーク構成を考える演習と解説
 *1回のお申込みで全2回(2日間)のお申込みとなります。
 *原則両方のセミナーにご参加いただきます。
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

 ~・,。★。,・~~・,。☆。,・~~・,。★。,・~~・,。☆。,・~~

「MPLS-VPNの仕組み」セミナーの教材セット
http://www.n-study.com/library/2010/07/nemplsvpn.html

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

ガンダムUC ep6の上映が2013年の3月に決まったようです。


http://www.gundam-unicorn.net/info/index.html


今までBlu-rayはAmazonで買っていましたが、今回は劇場限定の特典がいろい
ろと付くんですね。劇場で買ったら割引されないのですが、特典が欲しいので、
また、おっさんガノタ仲間と観に行って、Blu-rayも買ってこようと思います。


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2012 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/22 部数:  10,619部

他のメルマガを読む