ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1173 ルート再配送の設定例

カテゴリー: 2012年08月31日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
Geneが執筆したCisco CCNP用テキスト/問題集

【ROUTE】
          Cisco CCNP ROUTEテキスト 642-902対応
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284735/networkstudy-22/
              Cisco試験対策 Cisco CCNP ROUTE問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363304/networkstudy-22/

【SWITCH】
          Cisco CCNP SWITCHテキスト
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284832/networkstudy-22/
              Cisco試験対策 Cisco CCNP SWITCH問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363290/networkstudy-22/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【日本語で勉強できる】
  CCIE Routing & Switching ラボ模擬試験 Vol.1
  http://www.n-study.com/library/2010/07/ccie_routing_switching_vol1.html
  CCIE Routing & Switching Trouble Shooting対策 Part1
  http://www.n-study.com/library/2010/09/ccie_routing_switching_trouble.html
  MPLS-VPNトラブルシュートシナリオ Vol.1
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
  MPLS-VPN演習シナリオ Vol.1
  http://www.n-study.com/library/2012/05/ccie_mplsvpn_vol1_1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2012/8/31 Vol.1173 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆ルート再配送の設定例
	◆Geneが講師を担当するセミナー情報
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん)です。

今回はルート再配送の設定例です。
あまり現実的なネットワーク構成ではありませんが、複数の境界ルータで再配
送を行うときのアドミニストレイティブディスタンスを調整したルート制御の
例です。

ルート再配送の仕組みとそれに伴うルート制御について理解するための参考に
していただければと思います。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCNPを取得したい方へ

パソナテックさんでCCNP ROUTE/TSHOOTのトレーニングを開催予定です。Gene
が講師を担当します。
参加条件を満足している方は実質無料でトレーニングの受講と受験料の補助を
受けることができるプログラムです。
詳細は↓
http://www.pasonatech.co.jp/ca/ccnp/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「ルート再配送の設定例」

~ネットワーク構成~

http://www.n-study.com/network/image/ROUTE_redistribute01.html
図 ルート再配送 ネットワーク構成


~設定条件~

・R2、R3でEIGRPとOSPFの双方向再配送を行います。
・R1から172.16.100.0/24あての通信は、広帯域の回線を通じてルーティング
されるようにします。


~初期設定~
以下の設定は設定済みとします。

・ホスト名
・IPアドレス
・OSPF
  各ルータのインタフェースはネットワーク構成のとおりOSPFが有効化されて
  いてエリアに所属している
・EIGRP
  各ルータのインタフェースはネットワーク構成のとおりEIGRPが有効化されている
  自動集約の無効化


~設定~
【Step1:R2での再配送の設定】
R2でEIGRPとOSPFの双方向再配送の設定を行います。EIGRPへ再配送するときに
は、シードメトリックを忘れないように注意が必要です。OSPFへ再配送すると
きには、subnetsを忘れないように注意が必要です。

R2
------------------------------------------
router eigrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
!
router ospf 1
 redistribute eigrp 1 subnets
------------------------------------------


【Step2:R3での再配送の設定】
R3でEIGRPとOSPFの双方向再配送の設定を行います。R2と同様の設定を行います。

R2
------------------------------------------
router eigrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
!
router ospf 1
 redistribute eigrp 1 subnets
------------------------------------------


【Step3:ルーティングテーブルの確認】
R1~R4でルーティングテーブルを確認して、OSPFとEIGRPの双方向再配送が正
しく行われていることを確認します。

R1 show ip route
------------------------------------------
R1#show ip route 
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.100.0 [170/307200] via 192.168.1.2, 00:02:34, Ethernet0/0
D EX 192.168.4.0/24 [170/307200] via 192.168.1.2, 00:02:34, Ethernet0/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
D    192.168.2.0/24 [90/307200] via 192.168.1.2, 00:04:36, Ethernet0/0
D EX 192.168.3.0/24 [170/307200] via 192.168.1.2, 00:02:57, Ethernet0/0
------------------------------------------

R2 show ip route
------------------------------------------
R2#show ip route 
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.100.0 [110/65] via 192.168.3.4, 00:19:32, Serial1/0
O IA 192.168.4.0/24 [110/74] via 192.168.3.4, 00:19:32, Serial1/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
C    192.168.2.0/24 is directly connected, Ethernet0/1
C    192.168.3.0/24 is directly connected, Serial1/0
------------------------------------------

R3 show ip route
------------------------------------------
R3#show ip route 
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.100.0 [110/11] via 192.168.4.4, 00:29:55, Ethernet0/1
C    192.168.4.0/24 is directly connected, Ethernet0/1
D    192.168.1.0/24 [90/307200] via 192.168.2.2, 00:21:59, Ethernet0/0
C    192.168.2.0/24 is directly connected, Ethernet0/0
O IA 192.168.3.0/24 [110/74] via 192.168.4.4, 00:19:59, Ethernet0/1
------------------------------------------

R4 show ip route
------------------------------------------
R4#show ip route 
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, Loopback0
C    192.168.4.0/24 is directly connected, Ethernet0/0
O E2 192.168.1.0/24 [110/20] via 192.168.4.3, 00:03:38, Ethernet0/0
O E2 192.168.2.0/24 [110/20] via 192.168.4.3, 00:03:38, Ethernet0/0
C    192.168.3.0/24 is directly connected, Serial1/0
------------------------------------------

R1とR4では、上記の出力のようにそれぞれ他のルーティングドメインのルート
を外部ルートとして学習できていることがわかります。

【Step4:通信経路の確認】
R1から172.16.100.0/24へTracerouteを実行して通信経路を確認します。

R1 traceroute
------------------------------------------
R1#traceroute 172.16.100.4               

Type escape sequence to abort.
Tracing the route to 172.16.100.4

  1 192.168.1.2 76 msec 12 msec 8 msec
  2 192.168.3.4 8 msec *  40 msec
------------------------------------------

R1から172.16.100.0/24への経路は、R1→R2→R4となっています。広帯域のR3
を経由する経路ではありません。
R2は、172.16.100.0/24のルートをOSPFとEIGRPで学習します。異なるルーティ
ングプロトコルから同じルートを学習した場合は、アドミニストレイティブデ
ィスタンスによって、ルーティングテーブルに登録するルートが決まります。
OSPFのADは110で、EIGRP外部ルートは170です。そのため、R2はOSPFで学習し
た172.16.100.0/24のルートを優先します。たとえ、R3でOSPFからEIGRPへ再配
送するときのシードメトリックをいくら小さくしても、R2ではOSPFのルートが
採用されることになります。

http://www.n-study.com/network/image/ROUTE_redistribute02.html
図 R2での172.16.100.0/24のルート


【Step5:アドミニストレイディスタンスの調整】
172.16.100.0/24への経路を広帯域のR3経由にするために、R2でアドミニスト
レイティブディスタンスを変更します。R2では、EIGRPで学習した172.16.100.0/24
を優先するようにアドミニストレイティブディスタンスの設定を行います。

R2
------------------------------------------
router eigrp 1
 distance eigrp 90 90
------------------------------------------

※上記の設定は、EIGRP外部ルートのアドミニストレイティブディスタンスを
  小さくしています。OSPFのアドミニストレイティブディスタンスを大きくす
  る設定でも可能です。

【Step5:ルーティングテーブルと通信経路の確認】
R2でルーティングテーブルを確認して、172.16.100.0/24のルートがR3経由の
EIGRPルートとなっていることを確認します。

R2 show ip route
------------------------------------------
R2#show ip route 
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.100.0 [90/307200] via 192.168.2.3, 00:01:29, Ethernet0/1
D EX 192.168.4.0/24 [90/307200] via 192.168.2.3, 00:01:29, Ethernet0/1
C    192.168.1.0/24 is directly connected, Ethernet0/0
C    192.168.2.0/24 is directly connected, Ethernet0/1
C    192.168.3.0/24 is directly connected, Serial1/0
------------------------------------------


http://www.n-study.com/network/image/ROUTE_redistribute03.html
図 AD変更後のR2での172.16.100.0/24のルート


R1から172.16.100.0/24へTracerouteを実行して通信経路を確認すると、広帯
域のR3を経由した通信になっていることがわかります。


R1 traceroute
------------------------------------------
R1#traceroute 172.16.100.4

Type escape sequence to abort.
Tracing the route to 172.16.100.4

  1 192.168.1.2 44 msec 24 msec 8 msec
  2 192.168.2.3 4 msec 16 msec 8 msec
  3 192.168.4.4 8 msec *  64 msec
------------------------------------------


~最終的な設定抜粋~

R1
------------------------------------------
hostname R1
!
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
 network 192.168.1.0
 no auto-summary
------------------------------------------

R2
------------------------------------------
hostname R2
!
interface Ethernet0/0
 ip address 192.168.1.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.2.2 255.255.255.0
!         
interface Serial1/0
 ip address 192.168.3.2 255.255.255.0
!
router eigrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 192.168.1.0
 network 192.168.2.0
 distance eigrp 90 90
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1 subnets
 network 192.168.3.0 0.0.0.255 area 24
------------------------------------------

R3
------------------------------------------
hostname R3
!
interface Ethernet0/0
 ip address 192.168.2.3 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.4.3 255.255.255.0
!
router eigrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 192.168.2.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1 subnets
 network 192.168.4.0 0.0.0.255 area 34
------------------------------------------

R4
------------------------------------------
hostname R4
!
interface Loopback0
 ip address 172.16.100.4 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.4.4 255.255.255.0
!         
interface Serial1/0
 ip address 192.168.3.4 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 172.16.100.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 24
 network 192.168.4.0 0.0.0.255 area 34
------------------------------------------

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
12年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。



「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html
Geneが講師を担当するネットワークの基礎セミナーです。インターネットの設
定や通信の仕組みを4時間で学べます。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
2012/9/6 Get! CCNP Switch試験対策セミナー
~試験直前!模擬試験&徹底解説でラストスパート!~
http://www.pasonatech.co.jp/event/index.jsp?mode=2&d=on&no=3581

いざCCNP取得へ!その第一歩としてSwitch試験合格へ燃えている方に送る、
パソナテックのSwitch試験対策セミナー第3弾!

CCNP取得に向けた学習をする中で、自分の理解度を把握するには「模擬試験」
が最適です。これまでの学習の成果を試す絶好の機会でしょう。

でも、その機会にプラスして、問題作成者からの解法解説もあったとしたら。。?
その場で模擬&解説を受けることで、短時間でも濃密な試験対策が行えること
でしょう。

短時間でも出来るだけ効果の高い学習方法、その機会をパソナテックはご用意
しました!

今回は、本番試験を想定した短縮版にて、Switchの模擬試験を行います。
そして模擬試験の後にはたっぷり1時間、問題作成者から直々に問題解説も行
います。

模擬試験と問題解説の2段階構成で、
独学では追及できない些細な疑問まで、しっかり解説いたします。

CCNP Switch取得により、ネットワークプロフェッショナルを目指すエンジニアの方、
Switch試験が控えて居る方、ぜひご自身の学習理解度チェックのために。
ご参加お待ちしています。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

 ~・,。★。,・~~・,。☆。,・~~・,。★。,・~~・,。☆。,・~~

「MPLS-VPNの仕組み」セミナーの教材セット
http://www.n-study.com/library/2010/07/nemplsvpn.html

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

立秋も過ぎて暦の上ではもう秋ですが、日中はまだまだかなり暑いですね。

ここ数日、ネクタイを締めているのですが、汗だくです...
仕事自体は涼しい場所ですから、行き帰りだけへろへろになればなんとか
なりますが、外回りの営業さんを見ると心のなかで

「お疲れ様です」

と呟いてしまいます。

週末過ぎればこの暑さも多少和らぐみたいなので、あともう一息!
皆さん、残暑を乗り切りましょう。

└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2012 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,621部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,621部

他のメルマガを読む