ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1169 不連続サブネットにおけるEIGRPの設定

カテゴリー: 2012年08月03日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
Geneが執筆したCisco CCNP用テキスト/問題集

【ROUTE】
          Cisco CCNP ROUTEテキスト 642-902対応
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284735/networkstudy-22/
              Cisco試験対策 Cisco CCNP ROUTE問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363304/networkstudy-22/

【SWITCH】
          Cisco CCNP SWITCHテキスト
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284832/networkstudy-22/
              Cisco試験対策 Cisco CCNP SWITCH問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363290/networkstudy-22/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【日本語で勉強できる】
  CCIE Routing & Switching ラボ模擬試験 Vol.1
  http://www.n-study.com/library/2010/07/ccie_routing_switching_vol1.html
  CCIE Routing & Switching Trouble Shooting対策 Part1
  http://www.n-study.com/library/2010/09/ccie_routing_switching_trouble.html
  MPLS-VPNトラブルシュートシナリオ Vol.1
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
  MPLS-VPN演習シナリオ Vol.1
  http://www.n-study.com/library/2012/05/ccie_mplsvpn_vol1_1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2012/8/3 Vol.1169 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆不連続サブネットにおけるEIGRPの設定
	◆Geneが講師を担当するセミナー情報
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん)です。

今回は不連続サブネットでのEIGRPの設定についてです。
RIPもそうなんですが、自動集約が有効になっていると不連続サブネットのア
ドレス構成では、ルーティングテーブルに必要なルート情報が正しく登録され
ません。不連続サブネットでは、自動集約を無効化しなければいけません。
不連続サブネットで自動集約を無効化することで、きちんとルーティングでき
るようになる様子を見てください。

まぁ、不連続サブネットのアドレス構成をしているコト自体がダメですけどね・・・


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCNPを取得したい方へ

パソナテックさんでCCNP ROUTE/TSHOOTのトレーニングを開催予定です。Gene
が講師を担当します。
参加条件を満足している方は実質無料でトレーニングの受講と受験料の補助を
受けることができるプログラムです。
詳細は↓
http://www.pasonatech.co.jp/ca/ccnp/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「不連続サブネットにおけるEIGRPの設定」

~ネットワーク構成~

http://www.n-study.com/network/image/eigrp_discon01.html
図  不連続サブネットにおけるEIGRPの設定 ネットワーク構成


~設定条件~

・R1、R2間で正しくルーティングできるように設定します。

~確認条件~

・R1、R2間で正しくルーティングできることを確認します。

~初期設定~

以下の設定は設定済みとします。

・ホスト名
・IPアドレス
・EIGRP
  各ルータのインタフェースはネットワーク構成のとおりEIGRPが有効化されている
  それ以外の設定はデフォルト


~設定~
【Step1:ルーティングテーブルの確認】
R1、R2でルーティングテーブルを確認します。

R1 show ip route
------------------------------------------
R1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.1.1.0/24 is directly connected, Ethernet0/0
D       10.0.0.0/8 is a summary, 00:00:54, Null0
------------------------------------------

R2 show ip route
------------------------------------------
R2#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.2.2.0/24 is directly connected, Ethernet0/0
D       10.0.0.0/8 is a summary, 00:00:07, Null0
------------------------------------------

R1、R2のルーティングテーブルにはお互いのLAN側のルートが登録されていま
せん。そのため、LAN間の通信ができません。また、Null0向けの10.0.0.0/8の
ルートがルーティングテーブルに登録されています。R1とR2のルーティングテ
ーブルにお互いのLAN側のルートが登録されていない原因は、不連続サブネッ
トのアドレッシングと自動集約です。


http://www.n-study.com/network/image/eigrp_discon02.html
図 デフォルトのルートアドバタイズ


【Step2:自動集約の無効化】
不連続サブネットのアドレッシングで、EIGRPのルーティングを行うためには
自動集約を無効化します。

R1/R2 共通
------------------------------------------
router eigrp 1
 no auto-summary
------------------------------------------


【Step3:ルーティングテーブルと通信の確認】
自動集約を無効化したあと、ルーティングテーブルを確認します。

R1 show ip route
------------------------------------------
R1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2195456] via 192.168.12.2, 00:00:56, Serial1/0
C       10.1.1.0 is directly connected, Ethernet0/0
------------------------------------------

R2 show ip route
------------------------------------------
R2#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.2.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/2195456] via 192.168.12.1, 00:00:15, Serial1/0
------------------------------------------


http://www.n-study.com/network/image/eigrp_discon03.html
図 自動集約無効時のルートのアドバタイズ


R1、R2でお互いのLAN側のルートをルーティングテーブルに登録できるように
なったので、通信も可能です。

R1 ping
------------------------------------------
R1#ping 10.2.2.2 source 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/24 ms
------------------------------------------


~最終的な設定の抜粋~

R1
------------------------------------------
hostname R1
!
interface Ethernet0/0
 ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary
------------------------------------------

R2
------------------------------------------
hostname R2
!
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary
------------------------------------------


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
12年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。



「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html
Geneが講師を担当するネットワークの基礎セミナーです。インターネットの設
定や通信の仕組みを4時間で学べます。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
2012/8/7 Get! CCNP Switch試験対策セミナー
~スパニングツリーによる冗長化のポイント~
http://www.pasonatech.co.jp/event/index.jsp?mode=2&d=on&no=3534

「止まらない」ネットワークを構築するためには、さまざまな技術を組み合わ
せなければいけません。

スパニングツリーは「止まらない」ネットワークを構築する上で重要な技術で
す。CCNP Switch試験でも、スパニングツリーの問題が頻出します。また、実
環境でもスイッチを冗長化してスパニングツリーを利用するケースが多いでし
ょう。

本セミナーでは、標準のスパニングツリーおよび拡張されたRSTP/MSTPの仕組
みとCatalystスイッチの設定・検証を復習します。スパニングツリーの理解を
深めてCCNP Switch試験や実環境のネットワークで活用できるようになること
が目的です。

<主な内容>
・スパニングツリーの目的
・スパニングツリーの仕組み
・RSTPの仕組み
・MSTPの仕組み
・Catalystスイッチの設定・検証

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

 ~・,。★。,・~~・,。☆。,・~~・,。★。,・~~・,。☆。,・~~

「MPLS-VPNの仕組み」セミナーの教材セット
http://www.n-study.com/library/2010/07/nemplsvpn.html

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

体操の内村選手が金メダルを取りましたね!!リアルタイムで演技は見ていな
いなくて、テレビのニュースなどで見ただけですが、思わず息を呑む素晴らし
い演技でした。世界選手権を3連覇していてオリンピックでも当然大本命です。
プレッシャーに負けずに金メダルを獲得したのはお見事!!としか言いようが
ありません。

それにしても、いまの体操の技ってG難度なんてあるんですね。ぼくが子供の頃
はウルトラCとかだったのに・・・


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2012 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,621部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,621部

他のメルマガを読む