ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1151 デフォルトルートの生成 OSPF その1

カテゴリー: 2012年03月30日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
Geneが執筆したCisco CCNP用テキスト/問題集

【ROUTE】
          Cisco CCNP ROUTEテキスト 642-902対応
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284735/networkstudy-22/
              Cisco試験対策 Cisco CCNP ROUTE問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363304/networkstudy-22/

【SWITCH】
          Cisco CCNP SWITCHテキスト
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284832/networkstudy-22/
              Cisco試験対策 Cisco CCNP SWITCH問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363290/networkstudy-22/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【日本語で勉強できる】
  CCIE Routing & Switching ラボ模擬試験 Vol.1
  http://www.n-study.com/library/2010/07/ccie_routing_switching_vol1.html
  CCIE Routing & Switching Trouble Shooting対策 Part1
  http://www.n-study.com/library/2010/09/ccie_routing_switching_trouble.html
  MPLS-VPNトラブルシュートシナリオ Vol.1
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2012/3/30 Vol.1151 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆デフォルトルートの生成 OSPF その1
        ◆日経BP社 「3週間完全マスターネットワークスペシャリスト 2012年版」
               プレゼントのお知らせ
	◆Geneが講師を担当するセミナー情報
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCIEラボ試験に向けてMPLS-VPNの総仕上げに!
        「MPLS-VPNトラブルシュートシナリオ Vol.1」
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん)です。

RIP、EIGRPに続いてOSPFでのデフォルトルートの生成についてです。OSPFのデ
フォルトルートの生成は、前にも一度解説したことがあるのですが、あらため
てRIPやEIGRPのものと同じようなネットワーク構成で見ていきます。


※ネットワークスペシャリスト 2012年版のプレゼントのお申し込み締め切り
  は今日までです。秋のネットワークスペシャリストを受けようかなと考えて
  いる方は、ぜひご利用ください。


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「デフォルトルートの生成 OSPF その1」

~OSPFでのデフォルトルート生成~

デフォルトルートをOSPFルートとして生成して、他のルータにアドバタイズす
るためには、以下のようにいくつかの方法があります。

・default-information originateコマンド
・スタブエリアにする


~default-information originateコマンド~

【ネットワーク構成】


http://www.n-study.com/network/image/default_route_ospf01.html


【条件】

・R2がR3へデフォルトルートをOSPFでアドバタイズして、すべてのインタフェ
  ースの接続性を確保できるようにします。
・R2でのデフォルトルートの生成はdefault-information originateコマンド
  を利用するものとします。



【初期設定】


R1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 192.168.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
!
router ospf 100
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router ospf 100
 log-adjacency-changes
 network 192.168.3.0 0.0.0.255 area 1
 network 192.168.23.0 0.0.0.255 area 1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step1:R2でデフォルトルートの設定】

default-information originateコマンドでデフォルトルートを生成するため
には、すでにルーティングテーブルにデフォルトルートが登録されているこ
とが条件となります。R2でR1をネクストホップとするデフォルトルートをスタ
ティックルートとして設定します。


R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip route 0.0.0.0 0.0.0.0 192.168.12.1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step2:R2でデフォルトルートの生成】

R2でdefault-information originateコマンドによって、デフォルトルートを
OSPFルートとして生成します。

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router ospf 100
 default-information originate
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

※ alwaysのオプションをつけると、ルーティングテーブルにデフォルトルー
  トがなくてもデフォルトルートを生成します。


【Step3:デフォルトルートの確認】

R3のOSPF LSDBおよびルーティングテーブルを見て、R2からデフォルトルート
がアドバタイズされていることを確認します。

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#show ip ospf database 

            OSPF Router with ID (192.168.3.3) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.3.3     192.168.3.3     1259        0x80000008 0x002D93 2
192.168.23.2    192.168.23.2    16          0x80000008 0x00F223 1

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.2    192.168.23.2    1260        0x80000005 0x000A35

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.0     192.168.23.2    1266        0x80000002 0x00103D

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         192.168.23.2    16          0x80000001 0x007E4E 100
R3#show ip rou           
R3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
O IA 192.168.2.0/24 [110/11] via 192.168.23.2, 00:00:13, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
O*E2 0.0.0.0/0 [110/1] via 192.168.23.2, 00:00:13, Ethernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


default-information originateコマンドで生成したデフォルトルートは、LSA
タイプ5でアドバタイズされるため、ルーティングテーブル上では外部ルート
(O E2)であることがわかります。


【Step4:通信確認】

R3からR1へpingを実行してみると、正常に通信できることがわかります。

R3 
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#ping 172.16.1.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
R3#ping 172.16.2.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
12年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  日経BP社 「3週間完全マスターネットワークスペシャリスト 2012年版」
               プレゼントのお知らせ

www.amazon.co.jp/exec/obidos/ASIN/4822284913/networkstudy-22/ref=nosim/


日経BP社さんより、今年もネットワークスペシャリスト向けのテキストを出版
させていただきました。午後試験対策の実践的なテキストです。
2011年版をご利用いただいた何人かの方から、合格のご連絡をいただいて著者
としてとてもうれしく思いました。今年もこの本がネットワークスペシャリス
ト合格のお役に立てることを願っています。

各章の記述の見直しや追加の解説を行っています。1章~10章までで、ネットワ
ークスペシャリスト試験に必要なネットワーク技術の基礎的な仕組みを理解し
ていただくようにしています。1章から10章までは、次のような技術について
基礎的なことから解説しています。

第1章  プロトコルとネットワークアーキテクチャ
第2章  LAN
第3章  WANとインターネット
第4章  IPアドレッシング
第5章  IPルーティング
第6章  アプリケーションプロトコル
第7章  セキュリティ
第8章  IPテレフォニー
第9章  ストレージネットワーキング
第10章 サーバ仮想化技術

そして、11章では特に午後2の試験に対応できるように、下記のいろんな技術
を組み合わせと通信フローについて詳細に解説しています。

・インターネットを利用したシステム
・無線LANを利用したシステム
・IPテレフォニーのシステム
・ロードバランス
・検疫ネットワーク
・高可用性ネットワーク
・システムのバックアップ

最後に、2011年試験の午後1、午後2について詳細に解説しています。

単にネットワークスペシャリストの試験対策だけでなく、さまざまなネットワ
ークシステムを設計・構築する上でも参考にしていただける内容にしています。

この

「3週間完全マスターネットワークスペシャリスト 2012年版」

を5名の方にプレゼントします。ご希望の方は、下記フォーマットにご記入の
上、メールでご応募ください。


<件名>:NSP本プレゼント
<あて先>:info@n-study.com
<締切>:2012/3/30 23:59

【注意事項!!必ず読んでください】

過去に何度もyahooメールで連絡が取れないなどの問題が発生している都合上、
yahooメールでのご応募は、お控えください。

期限内に連絡が付かない場合は、当選が無効となります。期限後にご連絡を
頂いても対応致しかねますのでご了承ください。

amazonレビュー記入にはamazonアカウントが必要になります。
amazon利用で簡単無料で取得ができますが、いつまでも取得なさらず、お約束
頂いたにも関わらず、レビュー記入をなさらない方がいらっしゃいます。

レビューは購入を検討されている方にとって貴重な情報源となるため、記入を
お願いしています。
アカウントがない方でもご応募頂けますが、取得予定日を明記頂き、必ず
記入頂けますようお願いいたします。


本文フォーマット
※このフォーマットをコピペしてそのままお使いください。すべての項目が
記入必須事項です。記入漏れがあった場合、選外となります。

件名は、NSP本プレゼントでお願いします。
----------------------------------------------------------------
<お名前>:
(当選者発表時に使用しますので、ハンドルネームをご希望の方は
ハンドルネームでも構いません)
<メールアドレス>:

<注意事項は?>:読みました!・読んでいません
(※今回は追加事項があります。必ずご確認ください)

<amazonアカウント>:所持しています・○月○日迄に取得します
(※どちらか残してください。取得予定日の記入をお願いします)

<amazonレビュー記入>:約束します・約束しまません
(※どちらか残してください)

<本の活用方法>:







----------------------------------------------------------------

なお、抽選ではありません。本の活用方法を具体的に記入されている方に
プレゼントします。

ご応募はお一人様、1回です。
一人で何度も応募された方は、確認できた時点で抽選から外します。

また、プレゼント当選者の方には、本書活用法や感想などをamazonレビュー
にご記入いただきたいので、ご記入をお約束頂ける方のみ、ご応募ください。
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
(約束できますの項目にお答え頂いていない方も抽選から外しています)

皆様のご応募、お待ちしております。


└─────────────────────────ALL_@bout_Network─┘

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。

2012/4/7 CCIE Advanced Services ハンズオントレーニング
http://www.pasonatech.co.jp/event/index.jsp?no=3432

■概要
CCIE Routing & Switching ラボ試験のConfiguration内のAdvanced Serviceで
は、QoSやセキュリティ、ゲートウェイ冗長化などさまざまなネットワークサ
ービスの設定が求められます。このトレーニングでは、演習シナリオを実際に
実施していただいて、Advanced Serviceで必要な技術の設定ができるようにな
ることを目標としています。


【学習目標】
◇ラボ試験に対応できる技術力を身につける

【前提条件】
◇CCNPレベルの技術を習得されている方
◇3/15(木)開催の【CCIE Advanced Service】技術概要セミナーを受講済みの方

【学習項目】
◇QoS
◇ゲートウェイ冗長化プロトコル
◇NTP
◇DHCP
◇セキュリティ  


【トレーニング演習環境】
エミュレータ環境で、一人あたり複数台のルータを設定

「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html
Geneが講師を担当するネットワークの基礎セミナーです。インターネットの設
定や通信の仕組みを4時間で学べます。



また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

 ~・,。★。,・~~・,。☆。,・~~・,。★。,・~~・,。☆。,・~~

「MPLS-VPNの仕組み」セミナーの教材セットも発売されました!
http://www.n-study.com/library/2010/07/nemplsvpn.html

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘


┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

なんとビックリ。アロンソがマレーシアGPで優勝しました。今年は1勝もでき
ないんじゃないかと思っていました。しかも、2戦終わって、アロンソがラン
キング1位です。
ピットストップのタイミングがバッチリだったことと、アロンソの腕でもぎ
とった勝利という感じでした。ザウバーのペレスのほうがペースがよくて、
抜かれるとヒヤヒヤしましたが、あの難しいコンディションでミスすること
なく耐え切ったのは流石です。

次の中国GPまで少し間があくので、なんとかアップデートして他のチームに
対抗できるぐらいの競争力をつけていってもらいたいです。


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2012 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,621部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,621部

他のメルマガを読む