ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1149 デフォルトルートの生成 EIGRP その2

カテゴリー: 2012年03月16日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
Geneが執筆したCisco CCNP用テキスト/問題集

【ROUTE】
          Cisco CCNP ROUTEテキスト 642-902対応
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284735/networkstudy-22/
              Cisco試験対策 Cisco CCNP ROUTE問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363304/networkstudy-22/

【SWITCH】
          Cisco CCNP SWITCHテキスト
  http://www.amazon.co.jp/exec/obidos/ASIN/4822284832/networkstudy-22/
              Cisco試験対策 Cisco CCNP SWITCH問題集
  http://www.amazon.co.jp/exec/obidos/ASIN/4797363290/networkstudy-22/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【日本語で勉強できる】
  CCIE Routing & Switching ラボ模擬試験 Vol.1
  http://www.n-study.com/library/2010/07/ccie_routing_switching_vol1.html
  CCIE Routing & Switching Trouble Shooting対策 Part1
  http://www.n-study.com/library/2010/09/ccie_routing_switching_trouble.html
  MPLS-VPNトラブルシュートシナリオ Vol.1
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2012/3/16 Vol.1149 発行部数 約30000

Back Number: http://archive.mag2.com/0000046467/index.html
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆デフォルトルートの生成 EIGRP その2
	◆Geneが講師を担当するセミナー情報
    ◆終わりに

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCIEラボ試験に向けてMPLS-VPNの総仕上げに!
        「MPLS-VPNトラブルシュートシナリオ Vol.1」
  http://www.n-study.com/library/2012/02/ccie_mplsvpn_vol1.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん)です。

EIGRPでのデフォルトルートの生成です。2回目は、ルート集約を利用したデフ
ォルトルートの生成です。デフォルトルートは、あらゆるネットワークを集約
した究極の集約ルートです。デフォルトルートも集約ルートであるので、EIGRP
ではルート集約の設定でデフォルトルートを生成することができます。


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「デフォルトルートの生成 EIGRP その2」

~EIGRPでのデフォルトルート生成~

デフォルトルートをEIGRPルートとして生成して、他のルータにアドバタイズす
るためには、以下のようにいくつかの方法があります。

・スタティックルートのデフォルトルートをEIGRPへ再配送
・ルート集約
・default-networkコマンド



~スタティックルートのデフォルトルートをEIGRPへ再配送~

【ネットワーク構成】


http://www.n-study.com/network/image/eigrp_default_route01.html



【条件】

・R2がR3へデフォルトルートをEIGRPでアドバタイズして、すべてのインタフェ
  ースの接続性を確保できるようにします。
・デフォルトルートの生成はルート集約で行います。


【初期設定】


R1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 100
 network 192.168.23.0
 no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router eigrp 100
 network 192.168.3.0
 network 192.168.23.0
 no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step1:R3へルートをアドバタイズ】

R2からR3へ1つもルートをアドバタイズしていなければ、集約ルートを生成で
きません。R2で192.168.12.0/24もEIGRPプロセスに含んで、R3へルートをアド
バタイズできるようにします。また、R1へEIGRPパケットを送信しないように、
E0/0をパッシブインタフェースに指定します。

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router eigrp 100
 network 192.168.12.0
 passive-interface Ethernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step2:集約ルートとしてデフォルトルートを生成】

R2のE0/1で集約ルートの生成を行います。192.168.12.0/24のルートを集約し
て0.0.0.0/0をR3へアドバタイズするようにします。

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Ethernet0/1
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step3:デフォルトルートの確認】

R3のルーティングテーブルを見て、R2からデフォルトルートがアドバタイズさ
れていることを確認します。

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
D*   0.0.0.0/0 [90/307200] via 192.168.23.2, 00:01:06, Ethernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step4:通信確認】

R3からR1へpingを実行してみると、応答が返ってこないことがわかります。

R3 
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#ping 172.16.1.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
U.U.U
Success rate is 0 percent (0/5)
R3#ping 172.16.2.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
U.U.U
Success rate is 0 percent (0/5)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3からR1へのPingが失敗するのはR2のルーティングテーブルに必要なルート情
報が存在しないからです。R3はデフォルトルートを利用してR1宛てのパケット
をR2へ転送します。しかし、R2のルーティングテーブルにR1へルーティングす
るためのルート情報が存在しないので、パケットは破棄されます。


【Step5:デフォルトルートの設定】

R2でR1へルーティングするためのルート情報として、デフォルトルートをスタ
ティックルートとして設定します。

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip route 0.0.0.0 0.0.0.0 192.168.12.1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


【Step6:通信確認】

再度、R3からR1へpingを実行すると正常に応答が返ってくることが確認できます。


R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#ping 172.16.1.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/24 ms
R3#ping 172.16.2.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/16 ms
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
12年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。

2012/4/7 CCIE Advanced Services ハンズオントレーニング
http://www.pasonatech.co.jp/event/index.jsp?no=3432

■概要
CCIE Routing & Switching ラボ試験のConfiguration内のAdvanced Serviceで
は、QoSやセキュリティ、ゲートウェイ冗長化などさまざまなネットワークサ
ービスの設定が求められます。このトレーニングでは、演習シナリオを実際に
実施していただいて、Advanced Serviceで必要な技術の設定ができるようにな
ることを目標としています。


【学習目標】
◇ラボ試験に対応できる技術力を身につける

【前提条件】
◇CCNPレベルの技術を習得されている方
◇3/15(木)開催の【CCIE Advanced Service】技術概要セミナーを受講済みの方

【学習項目】
◇QoS
◇ゲートウェイ冗長化プロトコル
◇NTP
◇DHCP
◇セキュリティ  


【トレーニング演習環境】
エミュレータ環境で、一人あたり複数台のルータを設定

「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html
Geneが講師を担当するネットワークの基礎セミナーです。インターネットの設
定や通信の仕組みを4時間で学べます。



また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

 ~・,。★。,・~~・,。☆。,・~~・,。★。,・~~・,。☆。,・~~

「MPLS-VPNの仕組み」セミナーの教材セットも発売されました!
http://www.n-study.com/library/2010/07/nemplsvpn.html

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘


┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

今週末からF1が開幕です。テストから、去年のようなレッドブル独走にはなら
ないのでは?と予想されていますが、フェラーリがあんまりよくなさそうなの
が心配です。まったくいい話が聞こえてこない・・・チャンピオンは無理でも、
何勝かは挙げて、フェラーリの存在感を示して欲しいものです。


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2012 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,622部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,622部

他のメルマガを読む