ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか? Vol.1047 MPLS-VPNのトラブル その5

カテゴリー: 2010年04月30日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
『キーマンズネット』 http://www.n-study.com/books/2005/03/it.html
リクルートが提供するIT製品情報提供サイトです。無料で利用することができ
ます。

IT業界に身をおいている人は、エンジニアの方も営業職の方も関わりなく、キ
ーマンズネットへの登録をオススメします!
キーマンズネットへの登録は、以下のURLからバナーをクリックしてください。
http://www.n-study.com/books/2005/03/it.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2010/04/30 Vol.1047 発行部数 約30000

Back Number: http://blog.mag2.com/m/log/0000046467
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆MPLS-VPNのトラブル その5 【CCIEレベル】
        ◆Geneが講師を担当するセミナー情報
    ◆終わりに
  
 
└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん) です。

今回はMPLS-VPNのトラブル その5 です。
今回のトラブルはそんなに難しくありません。MPLS-VPNでPE-CE間のルーティ
ングでよく使うBGPとスタティックについての設定ミスを仕込んでいます。基
本的な設定とその検証ができるかどうかがポイントです。

今回のトラブルを仕込んでいるDynamips設定ファイルを下記よりダウンロード
できるようにしています。Dynamipsを使える方は、試してみてください。

http://www.n-study.com/MM_Vol1047.net

また、設定ミスがわかった方はぜひ回答をお寄せください。

宛先:info@n-study.com
件名:Vol.1047回答


MPLS-VPNのトラブルを2ヶ月ほど続けてきていますが、その1~その4の動画解
説を作成しています。有料版のPREMIUMの2010年4月のコンテンツです。MPLS-VPNの
トラブルその1~その4の動画解説をご覧になりたい方は、PREMIUMをご購読の
うえ、2010/4/30のPREMIUMを見てください。

ネットワークのおべんきょしませんか? PREMIUMの詳細・ご購読は以下のURL
より可能です。

http://www.mag2.com/m/P0000264.html


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
IT用語を調べるときには・・・キーマンズネット「IT単語帳」
http://www.n-study.com/network/2008/10/itit.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
                 無料レポートはじめました!!

・テクニカルエンジニア(ネットワーク)平成16年午後解説 ≪New≫
・テクニカルエンジニア(ネットワーク)平成15年午後解説 ≪New≫
・IPルーティング 再び 
・IPSecの概要
・IPアドレッシングを基本から復習しましょ!
・テクニカルエンジニア(ネットワーク)平成14年午後解説
・Ciscoルータのダイアルバックアップ
・レイヤ3スイッチの考え方とCisco Catalystスイッチの設定
・CiscoルータでのBGP集約

を1つのPDFファイルで読んでいただけます!お申し込みはこちらから↓
http://www.n-study.com/report.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
★PCのアイドル中に社会貢献「Folding@home」★
http://folding.stanford.edu/Japanese/Main
チームを作成しました!よろしければ、一緒にご参加ください!!
チーム番号:64236
チーム名:N-STUDY
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCIEラボ試験対策を効率よく進めるためのコンテンツ

「究めるOSPF」
http://www.n-study.com/library/2005/11/ccnaccnpccieospfospf.html

「究めるBGP」
http://www.n-study.com/library/2008/07/bgp_for_ccie_lab.html

「究めるIPマルチキャスト」
http://www.n-study.com/library/2009/02/ccie_ip_multicast.html

CCNPとCCIEラボ試験には、非常に大きな隔たりがあります。それを埋めようと
洋書やCCOなどWebの情報を基に勉強するのは、かなりの時間がかかります。
OSPF/BGP/IPマルチキャストについて、CCIEラボ試験レベルの技術を身につけ
ていただくためのコンテンツです。
CCIEラボ試験だけでなく、実際のネットワーク構築でも参考にしていただける
内容にしています。
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「MPLS-VPNのトラブル その5  【CCIEレベル】」

~ネットワーク構成~

下記のネットワーク構成で、MPLS-VPNを通じてR4とR5間の通信ができるように
したいと考えています。


http://www.n-study.com/network/image/mpls14.html
図 MPLS-VPN ネットワーク構成


ルータの役割は、次の通りです。

PEルータ:R1、R3
Pルータ :R2
CEルータ:R4、R5

PEルータであるR1、R3ではともにVRFとして次のように定義しています。

VRF名:VPN
RD:100:100
Import RT:100:100
Export RT:100:100


また、PE-CE間のルーティングは次の通りです。

R1-R4:BGP
R3-R5:スタティック


~設定概要~

各ルータで行われているMPLS-VPNでの通信に関連する設定は次の通りです。

R1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip vrf VPN
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding VPN
 ip address 10.14.14.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.0.3 remote-as 100
 neighbor 192.168.0.3 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 192.168.0.3 activate
  neighbor 192.168.0.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN
  redistribute eigrp 100
  neighbor 10.14.14.4 remote-as 65004
  no neighbor 10.14.14.4 activate
  no synchronization
 exit-address-family
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
interface Serial1/1
 ip address 192.168.23.2 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip vrf VPN
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding VPN
 ip address 10.35.35.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.23.3 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.0.1 remote-as 100
 neighbor 192.168.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 192.168.0.1 activate
  neighbor 192.168.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN
  redistribute static
  no synchronization
 exit-address-family
!
ip route 172.16.5.0 255.255.255.0 10.35.35.5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R4
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 172.16.4.4 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.14.14.4 255.255.255.0
!
router bgp 65004
 no synchronization
 bgp log-neighbor-changes
 network 172.16.4.0 mask 255.255.255.0
 neighbor 10.14.14.1 remote-as 100
 no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 172.16.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.35.35.5 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.35.35.3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


~トラブルの症状~

R4とR5間で通信ができません。R4およびR5のルーティングテーブルを見ると、
次のようになっています。

R4 show ip route
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#show ip route
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.4.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.14.14.0 is directly connected, FastEthernet0/
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5 show ip route
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.35.35.3 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.5.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.35.35.3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R4-R5間の通信に必要なルート情報がルーティングテーブルに登録されていま
せん。そのため、通信もできていません。

トラブルを解決するためにまずPE-CE間のルーティングについて確認しました。

R1-R4間のBGPのルーティングを次のshowコマンドで確認しています。

R1
show ip protocols vrf VPN
show ip bgp vpnv4 vrf VPN summary
show ip bgp vpnv4 vrf VPN

R4
show ip protocols
show ip bgp summary
show ip bgp 


R1 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip protocols vrf VPN
Routing Protocol is "bgp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Maximum path: 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.14.14.4            20      00:02:05
    192.168.0.3          200      00:15:15
  Distance: external 20 internal 200 local 200

R1#show ip bgp vpnv4 vrf VPN summary

R1#show ip bgp vpnv4 vrf VPN

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R4 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#show ip protocols
Routing Protocol is "bgp 65004"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Neighbor(s):
    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
    10.14.14.1
  Maximum path: 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.14.14.1            20      00:15:11
  Distance: external 20 internal 200 local 200

R4#show ip bgp summary
BGP router identifier 172.16.4.4, local AS number 65004
BGP table version is 6, main routing table version 6
1 network entries using 117 bytes of memory
1 path entries using 52 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 417 total bytes of memory
BGP activity 3/2 prefixes, 3/2 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.14.14.1      4   100      19      17        0    0    0 00:01:31 Active
R4#show ip bgp
BGP table version is 6, local router ID is 172.16.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.4.0/24    0.0.0.0                  0         32768 i
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


R3-R5間のスタティックのルーティングを次のshowコマンドで確認しています。


R3
show ip route vrf VPN

R5
show ip route


R3 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#show ip route vrf VPN

Routing Table: VPN
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.35.35.3 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.5.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.35.35.3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


これらのshowコマンドによって、PE-CE間のルーティングがうまくできていな
いことがわかりました。設定ミスを修正すると、R4-R5間の通信が可能になり
ました。


~問題~

・PE-CE間のルーティングができていない理由はなんですか?
・MPLS-VPN経由でR4-R5間の通信ができるようにするためには、どのように設
  定を修正すればよいですか?


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
たまにはシティーホテルでのんびり過ごしたいなぁって言う方は
一休ドットコムの高級ホテル・旅館の予約
≪ http://www.n-study.com/ikkyu/ ≫ 

 ホテル体験レポートもありますよ!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。


2010/5/29 CCIEラボ試験 トラブルシューティング攻略 Part2
ネクストワークス主催(有料)
http://www.nextworks.co.jp/02_seminar/gene01.html
2009年秋にCCIE Routing & Switchingのラボ試験が改訂されました。その際、
Trouble Shootingのパートが追加されています。2時間でルータ30台程度のネ
ットワークにおいて、条件に基づいてトラブルの原因となっている設定ミスを
修正するという形式です。
このセミナーは実践形式で、実際にGeneが作成したトラブルシューティングの
問題をやっていただきます。実際の試験よりも少し難しい内容のトラブルシュ
ーティングの問題です。実際に問題にあたっていただいた上で、トラブルを切
り分けるための確認コマンドや修正内容について解説します。実際にやってみ
て、そして、解説により効果的にCCIE Routing & Switchingラボ試験のTrouble
 Shootingについて対策できるようにしています。
なお、このセミナーはPart1/Part2の2回構成です。


「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html


また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【新バージョンのCCNAにいち早く対応! 日経BP刊】

Cisco CCNA ICND1テキスト 640-822[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283410/networkstudy-22/ref=nosim/

Cisco CCNA ICND2テキスト 640-816[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283429/networkstudy-22/ref=nosim/

新バージョンに対応した書籍では、一番早いはずです。これは、単に試験に
合格するだけではなくて、自信を持って「ネットワーク技術の基本は完
璧です!!」と言っていただけるようにするためです。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

ソフトバンクのアンドロイド携帯である「HTC Desire」が4/27から発売されま
した。予約しておこうと思っていたんですけど、近くのビックカメラの携帯電
話売り場はいつも混んでいて、「そのうちに・・・」と思っているウチに、予
約時期を逃してしまっていました。

「ま、発売日の店頭でも買えるだろう」と思っていたら、甘かったですね。何
件か回ってみたんですけど、軒並み予約完売だったみたいです。思っていた以
上に人気なのか、出荷が少ないのかよくわかりませんが。
発売日にオンラインの予約もできるようになったので、とりあえず、オンライ
ンで予約しておきました。早くて5月の下旬ぐらいになりそうです。スマート
フォンデビューは、まだもう少し先ですね。


└─────────────────────────ALL_@bout_Network─┘


                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2010 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|◆カプライト                                                         |
| http://cgi.kapu.biglobe.ne.jp/m/1676.html                           |
|◆E-Magazine                                                         |
| http://www.emaga.com/info/gene.html                                 |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/22 部数:  10,619部

他のメルマガを読む