ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1046 MPLS-VPNのトラブル その4 解答と解説

カテゴリー: 2010年04月23日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
『キーマンズネット』 http://www.n-study.com/books/2005/03/it.html
リクルートが提供するIT製品情報提供サイトです。無料で利用することができ
ます。

IT業界に身をおいている人は、エンジニアの方も営業職の方も関わりなく、キ
ーマンズネットへの登録をオススメします!
キーマンズネットへの登録は、以下のURLからバナーをクリックしてください。
http://www.n-study.com/books/2005/03/it.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2010/04/23 Vol.1046 発行部数 約30000

Back Number: http://blog.mag2.com/m/log/0000046467
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆MPLS-VPNのトラブル その4  解答と解説 【CCIEレベル】
        ◆Geneが講師を担当するセミナー情報
    ◆終わりに
  
 
└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん) です。

MPLS-VPNのトラブル その4 の解答と解説をお届けします。PE-CE間のルーティ
ングについてトラブルを仕込んでいました。

あんまり、実際にはやらないですけどね、こんな設定は。CE側でEIGRPを使う
ことはまずないです。OSPFのエリア構成も不自然な構成ですよね。でも、MPLS-VPN
でのルーティングの仕組みを理解するためには、重要です。あと、CCIEラボ試
験でも重要ですね。PE-CE間でのルーティングの考え方をしっかりと理解でき
るようにしていただきたいと思います。



━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
IT用語を調べるときには・・・キーマンズネット「IT単語帳」
http://www.n-study.com/network/2008/10/itit.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
                 無料レポートはじめました!!

・テクニカルエンジニア(ネットワーク)平成16年午後解説 ≪New≫
・テクニカルエンジニア(ネットワーク)平成15年午後解説 ≪New≫
・IPルーティング 再び 
・IPSecの概要
・IPアドレッシングを基本から復習しましょ!
・テクニカルエンジニア(ネットワーク)平成14年午後解説
・Ciscoルータのダイアルバックアップ
・レイヤ3スイッチの考え方とCisco Catalystスイッチの設定
・CiscoルータでのBGP集約

を1つのPDFファイルで読んでいただけます!お申し込みはこちらから↓
http://www.n-study.com/report.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
★PCのアイドル中に社会貢献「Folding@home」★
http://folding.stanford.edu/Japanese/Main
チームを作成しました!よろしければ、一緒にご参加ください!!
チーム番号:64236
チーム名:N-STUDY
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCIEラボ試験対策を効率よく進めるためのコンテンツ

「究めるOSPF」
http://www.n-study.com/library/2005/11/ccnaccnpccieospfospf.html

「究めるBGP」
http://www.n-study.com/library/2008/07/bgp_for_ccie_lab.html

「究めるIPマルチキャスト」
http://www.n-study.com/library/2009/02/ccie_ip_multicast.html

CCNPとCCIEラボ試験には、非常に大きな隔たりがあります。それを埋めようと
洋書やCCOなどWebの情報を基に勉強するのは、かなりの時間がかかります。
OSPF/BGP/IPマルチキャストについて、CCIEラボ試験レベルの技術を身につけ
ていただくためのコンテンツです。
CCIEラボ試験だけでなく、実際のネットワーク構築でも参考にしていただける
内容にしています。
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「MPLS-VPNのトラブル その4  解答と解説【CCIEレベル】」

~解答~

・PE-CE間のルーティングができていない理由はなんですか?

【R1-R4間】
R1のVRF「VPN」でEIGRPのAS番号が指定されていない。そのため、R1-R4間でEIGRP
ネイバーを確立できていない

【R3-R5間】
R5のOSPFエリア0とR3のスーパーバックボーン(MPLS-VPNバックボーン)が分断さ
れいている。そのため、R3はR5のエリア0のネットワーク(172.16.5.0/24)を認
識できない


・MPLS-VPN経由でR4-R5間の通信ができるようにするためには、どのように設
  定を修正すればよいですか?

R1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router eigrp 100
address-family ipv4 vrf VPN
 autonomous-system 100
!
router bgp 100
address-familiy ipv4 vrf VPN
 redistribute eigrp 100
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router ospf 35 vrf VPN
 area 35 virtual-link 5.5.5.5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router ospf 1
 area 35 virtual-link 3.3.3.3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


~ワンポイント~


・VRFでのEIGRP設定ではaddress-family内にAS番号を指定する
・OSPFエリア0とスーパーバックボーンが分断されている場合はVirtual-link
  が必要


~解説~

PEルータであるR1とR3で接続しているCEルータのR4、R5のルートを正しく認識
できていません。そのため、トラブルの原因はPEルータとCEルータのルーティ
ングにあることが推測できます。
R1-R4間のEIGRPとR3-R5間のOSPFのルーティングについてそれぞれ考えていきま
す。

【R1-R4間】
R1-R4間ではEIGRPを利用しています。しかし、R1-R4間でEIGRPネイバーを確立
できていません。その原因を調べるために一番分かりやすいのは、R1でshow ip 
protocols vrf VRPの出力を確認することです。


R1 show ip protocols vrf VPN
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip protocols vrf VPN
Routing Protocol is "bgp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Redistributing: eigrp
  Maximum path: 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.3          200      00:29:11
  Distance: external 20 internal 200 local 200

Routing Protocol is "eigrp"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: bgp 100, eigrp
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.14.14.1/32
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


これを見ると、VRF「VPN」のEIGRPではAS番号の情報がないことがわかります。
VRFでEIGRPを設定する場合は、address-familly内にAS番号の指定が必要です。
R1でVRF「VPN」のEIGRPの設定でAS番号の指定が抜けているので、R1とR4はEIGRP
ネイバーになれません。次のように、R1のVRF「VPN」のEIGRP設定でAS番号を
指定すれば、R1-R4間は正常にルーティングできるようになります。


R1 VRF「VPN」のEIGRPでAS番号を指定
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router eigrp 100
address-family ipv4 vrf VPN
 autonomous-system 100
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


VRF内でAS番号を指定したあと、EIGRPのインタフェース、ネイバー、ルーティ
ングテーブルを確認すると、次のようになります。


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip eigrp vrf VPN 100 interfaces
IP-EIGRP interfaces for process 100
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0      1282       0/1         7920           0
R1#show ip eigrp vrf VPN 100 neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.14.14.4              Fa0/0             11 00:00:40 1282  5000  0  4
R1#show ip rou
R1#show ip route vrf VPN

Routing Table: VPN
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.4.0 [90/156160] via 10.14.14.4, 00:00:46, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
B       10.35.35.0 [200/0] via 192.168.0.3, 00:27:27
C       10.14.14.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

また、R1がR3へ172.16.4.0/24のルートをMP-BGPでアドバタイズできるように、
VRF「VPN」のEIGRPをBGPへ再配送します。

R1 VRF「VPN」のEIGRPルートをBGPへ再配送
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router bgp 100
address-familiy ipv4 vrf VPN
 redistribute eigrp 100
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


これでR1-R4間のEIGRPのルーティングは問題ないことがわかります。


【R3-R5間】
R3-R5間はOSPFを利用しています。MPLS-VPNでPE-CE間のルーティングにOSPFを
利用するときはエリア構成に注意が必要です。MPLS-VPNバックボーンをスーパ
ーバックボーンとして、バックボーンエリアのように扱います。そのため、問
題のエリア構成ではスーパーバックボーンとエリア0が分断されてしまい、分
断されているエリア0のルートを正しく認識できません。
R3でOSPF LSDBを見ると、LSAタイプ3で172.16.5.0/24のルートを学習しています。


R3 show ip ospf 35 database/show ip ospf 35 database summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#sh ip ospf 35 database

            OSPF Router with ID (3.3.3.3) (Process ID 35)

                Router Link States (Area 35)

Link ID         ADV Router      Age         Seq#       Checksum Link count
3.3.3.3         3.3.3.3         1821        0x80000002 0x00E28B 1
5.5.5.5         5.5.5.5         1822        0x80000002 0x0060FD 1

                Net Link States (Area 35)

Link ID         ADV Router      Age         Seq#       Checksum
10.35.35.5      5.5.5.5         1822        0x80000001 0x006D43

                Summary Net Link States (Area 35)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.5.0      5.5.5.5         1863        0x80000001 0x004026
R3#show ip ospf 35 database summary

            OSPF Router with ID (3.3.3.3) (Process ID 35)

                Summary Net Link States (Area 35)

  LS age: 1981
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 172.16.5.0 (summary Network Number)
  Advertising Router: 5.5.5.5
  LS Seq Number: 80000001
  Checksum: 0x4026
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


しかし、スーパーバックボーンとエリア0が分断されていて、エリア構成が正
しくないので172.16.5.0/24に対するLSAタイプ3のルートは利用されていませ
ん。分断されているスーパーバックボーンとエリア0をVirtual-linkで接続し
ます。R3とR5で次のようにVirtual-linkの設定を行います。


R3 R5に対するVirtual-link
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router ospf 35 vrf VPN
 area 35 virtual-link 5.5.5.5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5 R3に対するVirtual-link
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router ospf 1
 area 35 virtual-link 3.3.3.3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


http://www.n-study.com/network/image/mpls13.html
図 スーパーバックボーンとエリア0の接続


Virtual-linkを設定すれば、R3はR5の172.16.5.0/24のルートを正しく認識して、
ルーティングテーブルに登録します。


R3 show ip route vrf VPN
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#show ip route vrf VPN

Routing Table: VPN
~省略~
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
B       172.16.4.0 [200/156160] via 192.168.0.1, 00:06:53
O       172.16.5.0 [110/2] via 10.35.35.5, 00:05:30, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
B       10.14.14.0 [200/0] via 192.168.0.1, 00:06:53
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


これでR3-R5間のルーティングも問題なく行えるようになります。


最終的に、R4、R5ではお互いのルートをルーティングテーブルに登録できるよ
うになり、通信も可能です。


R4 show ip route/ping 172.16.5.5 source 172.16.4.4
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#show ip route
~省略~
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.4.0 is directly connected, Loopback0
D EX    172.16.5.0 [170/30720] via 10.14.14.1, 00:08:11, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
D EX    10.35.35.0 [170/30720] via 10.14.14.1, 00:09:58, FastEthernet0/0
C       10.14.14.0 is directly connected, FastEthernet0/0
R4#ping 172.16.5.5 source 172.16.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.5.5, timeout is 2 seconds:
Packet sent with a source address of 172.16.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/31/52 ms
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
たまにはシティーホテルでのんびり過ごしたいなぁって言う方は
一休ドットコムの高級ホテル・旅館の予約
≪ http://www.n-study.com/ikkyu/ ≫ 

 ホテル体験レポートもありますよ!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。


2010/4/24 CCIEラボ試験 トラブルシューティング攻略 Part1
2010/5/29 CCIEラボ試験 トラブルシューティング攻略 Part2
ネクストワークス主催(有料)
http://www.nextworks.co.jp/02_seminar/gene01.html
2009年秋にCCIE Routing & Switchingのラボ試験が改訂されました。その際、
Trouble Shootingのパートが追加されています。2時間でルータ30台程度のネ
ットワークにおいて、条件に基づいてトラブルの原因となっている設定ミスを
修正するという形式です。
このセミナーは実践形式で、実際にGeneが作成したトラブルシューティングの
問題をやっていただきます。実際の試験よりも少し難しい内容のトラブルシュ
ーティングの問題です。実際に問題にあたっていただいた上で、トラブルを切
り分けるための確認コマンドや修正内容について解説します。実際にやってみ
て、そして、解説により効果的にCCIE Routing & Switchingラボ試験のTrouble
 Shootingについて対策できるようにしています。
なお、このセミナーはPart1/Part2の2回構成です。

2010/4/25 MPLS-VPNの仕組み
オフィス・エヌ・スタディ主催(有料)
http://www.n-study.com/page/mpls-vpn.html
企業の拠点間を接続するサービスとして、IP-VPNが広く利用されています。IP-VPN
はMPLSによって実現されていることが多いです。このセミナーでは、MPLS-VPN
の仕組みを解説し、Ciscoルータでの設定と検証について理解を深めていただ
くことを目的としています。MPLSを勉強するための日本語で読める書籍などは
なかなかありません。MPLS-VPNの仕組みを知りたいという方にオススメです。
また、2009年秋にCCIE Routing & Switchingのラボ試験が改訂されて、MPLS-VPN
も出題範囲に含まれるようになっています。CCIE R&S ラボ試験のために、MPLS-VPN
を勉強したい方にもオススメです。


「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html


また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【新バージョンのCCNAにいち早く対応! 日経BP刊】

Cisco CCNA ICND1テキスト 640-822[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283410/networkstudy-22/ref=nosim/

Cisco CCNA ICND2テキスト 640-816[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283429/networkstudy-22/ref=nosim/

新バージョンに対応した書籍では、一番早いはずです。これは、単に試験に
合格するだけではなくて、自信を持って「ネットワーク技術の基本は完
璧です!!」と言っていただけるようにするためです。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

今年のフェラーリは初戦1-2で最高のスタートだったんですが、以来、どうも
リズムが良くないです・・・ついに、チャンピオンシップのリードをマクラー
レンに奪われてしまいました。ま、まだ始まったばかりなんで、この時点の得
点差はあんまり気にしなくていいとは思いますが・・・

それにしても、2007年からのフェラーリはドライからウェット、ウェットから
ドライのコンディション変化に対する状況判断が極端に下手になったような気
がします。今回の中国GPもマッサかアロンソのどっちかはステイさせておけな
かったんでしょうか?序盤の無駄なタイヤ交換が大きな敗因です。レッドブル
も同じミスジャッジしたので、レッドブルとの差はあまりたいしたことないで
す。でも、マクラーレンにしてやられたのはイタイ。

なんかいや~な雰囲気ですが、ヨーロッパラウンドの初戦は、アロンソの地元
スペインです。また、フェラーリに流れを引き寄せてもらいたいです。



└─────────────────────────ALL_@bout_Network─┘
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

2010/04/25(日)開催!NE向けセミナー「MPLS-VPNの仕組み」残席わずか!
本日申込締切

http://www.n-study.com/page/mpls-vpn.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2010 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|◆カプライト                                                         |
| http://cgi.kapu.biglobe.ne.jp/m/1676.html                           |
|◆E-Magazine                                                         |
| http://www.emaga.com/info/gene.html                                 |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/22 部数:  10,619部

他のメルマガを読む