ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1044 MPLS-VPNのトラブル その3 解答と解説

カテゴリー: 2010年04月09日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
『キーマンズネット』 http://www.n-study.com/books/2005/03/it.html
リクルートが提供するIT製品情報提供サイトです。無料で利用することができ
ます。

IT業界に身をおいている人は、エンジニアの方も営業職の方も関わりなく、キ
ーマンズネットへの登録をオススメします!
キーマンズネットへの登録は、以下のURLからバナーをクリックしてください。
http://www.n-study.com/books/2005/03/it.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2010/04/09 Vol.1044 発行部数 約30000

Back Number: http://blog.mag2.com/m/log/0000046467
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆MPLS-VPNのトラブル その3  解答と解説 【CCIEレベル】
        ◆Geneが講師を担当するセミナー情報
    ◆終わりに
  
 
└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん) です。

MPLS-VPNのトラブル その3 について解答と解説をお届けします。
設定ミスが2つあって結構難しい内容ですね。この設定ミスを的確にshowコマ
ンドで切り分けて修正できるレベルであれば、MPLS-VPNの理解はバッチリです。

次回もMPLS-VPNのトラブルの問題を作ります。もうちょっと難しくなっていき
ます。


※4/25にMPLS-VPNについてのセミナーを開催します。MPLS-VPNの仕組みと設定・
  検証を勉強したい方にオススメです。
  http://www.n-study.com/page/mpls-vpn.html



━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
IT用語を調べるときには・・・キーマンズネット「IT単語帳」
http://www.n-study.com/network/2008/10/itit.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
                 無料レポートはじめました!!

・テクニカルエンジニア(ネットワーク)平成16年午後解説 ≪New≫
・テクニカルエンジニア(ネットワーク)平成15年午後解説 ≪New≫
・IPルーティング 再び 
・IPSecの概要
・IPアドレッシングを基本から復習しましょ!
・テクニカルエンジニア(ネットワーク)平成14年午後解説
・Ciscoルータのダイアルバックアップ
・レイヤ3スイッチの考え方とCisco Catalystスイッチの設定
・CiscoルータでのBGP集約

を1つのPDFファイルで読んでいただけます!お申し込みはこちらから↓
http://www.n-study.com/report.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
★PCのアイドル中に社会貢献「Folding@home」★
http://folding.stanford.edu/Japanese/Main
チームを作成しました!よろしければ、一緒にご参加ください!!
チーム番号:64236
チーム名:N-STUDY
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCIEラボ試験対策を効率よく進めるためのコンテンツ

「究めるOSPF」
http://www.n-study.com/library/2005/11/ccnaccnpccieospfospf.html

「究めるBGP」
http://www.n-study.com/library/2008/07/bgp_for_ccie_lab.html

「究めるIPマルチキャスト」
http://www.n-study.com/library/2009/02/ccie_ip_multicast.html

CCNPとCCIEラボ試験には、非常に大きな隔たりがあります。それを埋めようと
洋書やCCOなどWebの情報を基に勉強するのは、かなりの時間がかかります。
OSPF/BGP/IPマルチキャストについて、CCIEラボ試験レベルの技術を身につけ
ていただくためのコンテンツです。
CCIEラボ試験だけでなく、実際のネットワーク構築でも参考にしていただける
内容にしています。
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「MPLS-VPNのトラブル その3  解答と解説 【CCIEレベル】」

~解答~

・PE-CE間のルーティングには問題がないのに、R4-R5間で通信できない理由は
  なんですか?

R1でVRF「VPN」のImport RTの設定が間違っているため、R2からのMP-BGPのル
ートを正しく受信できていない。
また、R1でVRF「VPN」のOSPFルートをMP-BGPへ再配送する設定が抜けている。
そのため、R1からR3へMP-BGPルートが送信されない。
上記の2点の設定ミスのため、R4、R5に必要なルートが伝わらず、通信できな
い


・MPLS-VPN経由でR4-R5間の通信ができるようにするためには、どのように設
  定を修正すればよいですか?


R1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip vrf VPN
 no route-target import
 route-target import 100:100
!
router bgp 100
 address-family ipv4 vrf VPN
  redistribute ospf 14
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


~解説~

今回の設定ミスは、次の2点です。

・RTのミス
・再配送の設定漏れ


【RTのミス】
まず、RTの仕組みを簡単に解説し、RTのミスについて考えます。
MPLS-VPNバックボーンのPEルータ間で、MP-BGPによって接続しているサイトの
VPNルートを交換します。MP-BGPのそれぞれのルートには、VRFを識別するため
にRoute Target(RT)が付加されています。RTはとても重要です。MP-BGPのルー
トのRTを見て、そのルートをどのVRFで扱うべきかを決めています。
次の図は、RTによってMP-BGPルートを扱うVRFを決めている様子を簡単に表し
ています。


http://www.n-study.com/image/mpls09.html
図 RTによるVRFの決定


PEルータのMP-BGPテーブルには、次の2つのMP-BGPルートがあります。

1. RD1:192.168.1.0/24 RT100:100
2. RD2:192.168.1.0/24 RT200:200

そして、PEルータには「VPN1」と「VPN2」のVRFがあります。VPN1のVRFはImport RT
として100:100が決められています。そのため、VPN1のVRFで扱うMP-BGPルート
はRT 100:100が付加されている1.のルートです。同様に考えてVPN2のVRFで扱
うルートはRT 200:200が付加されている2.のルートになります。
このようにRTによって、どのVRFでMP-BGPルートを扱うかを決定しているので、
RTが正しくなければルートがうまく伝わりません。

ここで問題の構成のPEルータであるR1とR3でのRTについて確認します。VRFの
RTはshow ip vrf detailでわかります。

R1 show ip vrf detail
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip vrf detail
VRF VPN; default RD 100:100; default VPNID <not set>
  Interfaces:
    Fa0/0
  Connected addresses are not in global routing table
  Export VPN route-target communities
    RT:100:100
  Import VPN route-target communities
    RT:100:101
  No import route-map
  No export route-map
  VRF label distribution protocol: not configured
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3 show ip vrf detail
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#show ip vrf detail
VRF VPN; default RD 100:100; default VPNID <not set>
  Interfaces:
    Fa0/0
  Connected addresses are not in global routing table
  Export VPN route-target communities
    RT:100:100
  Import VPN route-target communities
    RT:100:100
  No import route-map
  No export route-map
  VRF label distribution protocol: not configured
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R1はVRF「VPN」について、

Import RT 100:101
Export RT 100:100

が設定されていることがわかります。そして、R3ではVRF「VPN」について

Import RT 100:100
Export RT 100:100

が設定されています。
R3からは、RT 100:100が付加されるのですが、それを扱うべきR1のVRF「VPN」
のImport RTの設定が間違っています。R1のVRF「VPN」のImport RTを100:100に
しなければいけません。次の設定は、R1のVRF「VPN」のImport RTを100:100に
するためのものです。


R1 Import RTの修正
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip vrf VPN
 no route-target import
 route-target import 100:100
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


R1でImport RTを修正すると、MP-BGPテーブルは次のようにR3から受信したル
ートを確認できるようになります。また、VRF「VPN」のルーティングテーブル
にR3から受信したルートがBGPルートとして登録されます。


R1 show ip bgp vpnv4 all/show ip route vrf VPN
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip bgp vpnv4 all
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf VPN)
*>i10.35.35.0/24    192.168.0.3              0    100      0 ?
*>i172.16.5.0/24    192.168.0.3              2    100      0 ?
R1#show ip route vrf VPN

Routing Table: VPN
~省略~
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
O       172.16.4.0 [110/2] via 10.14.14.4, 00:04:57, FastEthernet0/0
B       172.16.5.0 [200/2] via 192.168.0.3, 00:04:31
     10.0.0.0/24 is subnetted, 2 subnets
B       10.35.35.0 [200/0] via 192.168.0.3, 00:04:31
C       10.14.14.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


図 RT修正後のR1でのMP-BGPテーブル、ルーティングテーブル
http://www.n-study.com/image/mpls10.html


そして、R3から受信したMP-BGPルートはVRF「VPN」のOSPFへ再配送されて、R4
へアドバタイズされます。R4のルーティングテーブルを見ると、R5のネットワ
ークのルートが登録されます。


R4 show ip route
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#show ip route
~省略~
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.4.0 is directly connected, Loopback0
O E2    172.16.5.0 [110/2] via 10.14.14.1, 00:06:49, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
O E2    10.35.35.0 [110/1] via 10.14.14.1, 00:06:49, FastEthernet0/0
C       10.14.14.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━



【再配送の設定漏れ】
R1はR4から受信したOSPFルートをMP-BGPルートとしてR3へアドバタイズしなけ
ればいけません。ですが、再配送の設定漏れのためにそれができていません。
CEルータから受信したルートをMP-BGPルートとして他のPEルータへアドバタイ
ズするためには、再配送が必要です。R1でVRF「VPN」のOSPFからMP-BGPへの再
配送の設定が抜けています。
R1でのVRF「VPN」のOSPFからMP-BGPの再配送に関する設定は次の通りです。


R1 VRF「VPN」のOSPFからMP-BGPへの再配送
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router bgp 100
 address-family ipv4 vrf VPN
  redistribute ospf 14
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


再配送の設定をすることで、R1はVRF「VPN」のOSPFルート 10.14.14.0/24と
172.16.4.0/24 をMP-BGPルートとして生成します。R1のMP-BGPテーブルを確認
すると、次のようになります。


R1 show ip bgp vpnv4 all
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#sh ip bgp vpnv4 all
BGP table version is 9, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf VPN)
*> 10.14.14.0/24    0.0.0.0                  0         32768 ?
*>i10.35.35.0/24    192.168.0.3              0    100      0 ?
*> 172.16.4.0/24    10.14.14.4               2         32768 ?
*>i172.16.5.0/24    192.168.0.3              2    100      0 ?
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


http://www.n-study.com/image/mpls11.html
図 R1でのMP-BGPルートの生成


R1からR3へ10.14.14.0/24と172.16.4.0/24がアドバタイズされ、最終的にR5ま
で伝わります。R5のルーティングテーブルは次のようになっています。

R5 show ip route
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R5#show ip route
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
O E2    172.16.4.0 [110/2] via 10.35.35.3, 00:04:09, FastEthernet0/0
C       172.16.5.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
O E2    10.14.14.0 [110/1] via 10.35.35.3, 00:04:09, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


以上のように、

・R1でのImport RTの修正
・R1でのVRFのOSPFMP-BGPへの再配送の追加

を行うことで、R4、R5で正しくルートを学習できるようになりました。その結
果、通信も可能になります。


R4、R5間の通信確認
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#ping 172.16.5.5 source 172.16.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.5.5, timeout is 2 seconds:
Packet sent with a source address of 172.16.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/76 ms
R5#ping 172.16.4.4 source 172.16.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/31/64 ms
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━



◆◆◇━━━━……‥‥・・・ ・  ・ ・・・‥‥…━━━━◇◆◆

待望のMPLS-VPNの仕組み解説セミナー、4/25(日)に開催!!
お申込、詳細は以下をご覧ください。

http://www.n-study.com/page/mpls-vpn.html

◆◆◇━━━━……‥‥・・・ ・  ・ ・・・‥‥…━━━━◇◆◆

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
たまにはシティーホテルでのんびり過ごしたいなぁって言う方は
一休ドットコムの高級ホテル・旅館の予約
≪ http://www.n-study.com/ikkyu/ ≫ 

 ホテル体験レポートもありますよ!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。


2010/4/24 CCIEラボ試験 トラブルシューティング攻略 Part1
2010/5/29 CCIEラボ試験 トラブルシューティング攻略 Part2
ネクストワークス主催(有料)
http://www.nextworks.co.jp/02_seminar/gene01.html
2009年秋にCCIE Routing & Switchingのラボ試験が改訂されました。その際、
Trouble Shootingのパートが追加されています。2時間でルータ30台程度のネ
ットワークにおいて、条件に基づいてトラブルの原因となっている設定ミスを
修正するという形式です。
このセミナーは実践形式で、実際にGeneが作成したトラブルシューティングの
問題をやっていただきます。実際の試験よりも少し難しい内容のトラブルシュ
ーティングの問題です。実際に問題にあたっていただいた上で、トラブルを切
り分けるための確認コマンドや修正内容について解説します。実際にやってみ
て、そして、解説により効果的にCCIE Routing & Switchingラボ試験のTrouble
 Shootingについて対策できるようにしています。
なお、このセミナーはPart1/Part2の2回構成です。

2010/4/25 MPLS-VPNの仕組み
オフィス・エヌ・スタディ主催(有料)
http://www.n-study.com/page/mpls-vpn.html
企業の拠点間を接続するサービスとして、IP-VPNが広く利用されています。IP-VPN
はMPLSによって実現されていることが多いです。このセミナーでは、MPLS-VPN
の仕組みを解説し、Ciscoルータでの設定と検証について理解を深めていただ
くことを目的としています。MPLSを勉強するための日本語で読める書籍などは
なかなかありません。MPLS-VPNの仕組みを知りたいという方にオススメです。
また、2009年秋にCCIE Routing & Switchingのラボ試験が改訂されて、MPLS-VPN
も出題範囲に含まれるようになっています。CCIE R&S ラボ試験のために、MPLS-VPN
を勉強したい方にもオススメです。


「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html


また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【新バージョンのCCNAにいち早く対応! 日経BP刊】

Cisco CCNA ICND1テキスト 640-822[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283410/networkstudy-22/ref=nosim/

Cisco CCNA ICND2テキスト 640-816[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283429/networkstudy-22/ref=nosim/

新バージョンに対応した書籍では、一番早いはずです。これは、単に試験に
合格するだけではなくて、自信を持って「ネットワーク技術の基本は完
璧です!!」と言っていただけるようにするためです。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

もうHTC Desireの予約ができるんですね。でも、オンラインではできないよう
です。めんどくさい・・・
今日、打ち合わせの帰りにでも、HTC Desireの予約をしてこようと思っていま
す。


└─────────────────────────ALL_@bout_Network─┘

                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2010 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|◆カプライト                                                         |
| http://cgi.kapu.biglobe.ne.jp/m/1676.html                           |
|◆E-Magazine                                                         |
| http://www.emaga.com/info/gene.html                                 |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,621部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,621部

他のメルマガを読む