ネットワークのおべんきょしませんか?

ネットワークのおべんきょしませんか?Vol.1041 MPLS-VPNのトラブル その2

カテゴリー: 2010年03月19日
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
『キーマンズネット』 http://www.n-study.com/books/2005/03/it.html
リクルートが提供するIT製品情報提供サイトです。無料で利用することができ
ます。

IT業界に身をおいている人は、エンジニアの方も営業職の方も関わりなく、キ
ーマンズネットへの登録をオススメします!
キーマンズネットへの登録は、以下のURLからバナーをクリックしてください。
http://www.n-study.com/books/2005/03/it.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
| ネットワークのおべんきょしませんか?                                |
| http://www.n-study.com/                                             |
└─────────────────────────ALL_@bout_Network─┘
2010/03/19 Vol.1041 発行部数 約30000

Back Number: http://blog.mag2.com/m/log/0000046467
有料版PREMIUM: http://www.n-study.com/premium/index.htm
広告掲載について: http://www.n-study.com/2006/12/post_1.html
WEBサイト広告掲載:http://www.n-study.com/2006/12/web.html
コンテンツ提供: http://www.n-study.com/2006/12/post_2.html

※メルマガ解除は自己責任で行ってください。発行者ではいっさい対応しませ
ん。メルマガの最後に各発行スタンドへのリンクを記載しています

┌──ALL_@bout_Network────────────────────────┐

~INDEX~

        ◆はじめに
        ◆MPLS-VPNのトラブル その2 【CCIEレベル】
        ◆Geneが講師を担当するセミナー情報
    ◆終わりに
 

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ネットワークインフラがかなり整ってきて、そのインフラ上でさまざまなサー
ビスやアプリケーションが提供されるようになってきています。
ネットワークのサービスやアプリケーションの最新情報をキャッチアップする
ために、日経コミュニケーションはとても役に立ちます。
いろんな企業ネットワークの構築事例も載せられていて、自分自身の技術の引
き出しを増やすのにとてもよい雑誌です。

日経コミュニケーションのご購読申し込みは下記URLから↓
http://www.n-study.com/books/2005/06/post.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「はじめに」

こんにちは、発行者の Gene(じーん) です。

MPLS-VPNのトラブル その2です。MPLS-VPNは構成する機器がたくさんあって、
設定もいっぱいやらなくてはいけません。なので、設定漏れや設定ミスはよく
やってしまいがちです。設定漏れや設定ミスを少なくするためには、仕組みを
理解した上でそれぞれの設定コマンドの意味をきちんと把握することがポイン
トです。そして、設定が正しいかどうかを適切なshowコマンドを使えるかどう
かがポイントです。

MPLS-VPNのトラブル その2は、すこしネタバレですが、PEルータでの設定漏れ
です。たった1つのコマンドが抜けているだけなんですが、適切なshowコマン
ドでどのルータでどんなコマンドが抜けているのかを考えてください。show running-config
だけでもわかるとは思うんですが、show running-configだけだと時間がかか
るでしょう。

※4/25にMPLS-VPNについてのセミナーを開催します。MPLS-VPNの仕組みと設定・
  検証を勉強したい方にオススメです。
  http://www.n-study.com/page/mpls-vpn.html



━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
IT用語を調べるときには・・・キーマンズネット「IT単語帳」
http://www.n-study.com/network/2008/10/itit.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
                 無料レポートはじめました!!

・テクニカルエンジニア(ネットワーク)平成16年午後解説 ≪New≫
・テクニカルエンジニア(ネットワーク)平成15年午後解説 ≪New≫
・IPルーティング 再び 
・IPSecの概要
・IPアドレッシングを基本から復習しましょ!
・テクニカルエンジニア(ネットワーク)平成14年午後解説
・Ciscoルータのダイアルバックアップ
・レイヤ3スイッチの考え方とCisco Catalystスイッチの設定
・CiscoルータでのBGP集約

を1つのPDFファイルで読んでいただけます!お申し込みはこちらから↓
http://www.n-study.com/report.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
★PCのアイドル中に社会貢献「Folding@home」★
http://folding.stanford.edu/Japanese/Main
チームを作成しました!よろしければ、一緒にご参加ください!!
チーム番号:64236
チーム名:N-STUDY
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
CCIEラボ試験対策を効率よく進めるためのコンテンツ

「究めるOSPF」
http://www.n-study.com/library/2005/11/ccnaccnpccieospfospf.html

「究めるBGP」
http://www.n-study.com/library/2008/07/bgp_for_ccie_lab.html

「究めるIPマルチキャスト」
http://www.n-study.com/library/2009/02/ccie_ip_multicast.html

CCNPとCCIEラボ試験には、非常に大きな隔たりがあります。それを埋めようと
洋書やCCOなどWebの情報を基に勉強するのは、かなりの時間がかかります。
OSPF/BGP/IPマルチキャストについて、CCIEラボ試験レベルの技術を身につけ
ていただくためのコンテンツです。
CCIEラボ試験だけでなく、実際のネットワーク構築でも参考にしていただける
内容にしています。
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「MPLS-VPNのトラブル その2 【CCIEレベル】」

~ネットワーク構成~

下記のネットワーク構成で、MPLS-VPNを通じてR4とR5間の通信ができるように
したいと考えています。


http://www.n-study.com/network/image/mpls04.html
図 MPLS-VPN ネットワーク構成


ルータの役割は、次の通りです。

PEルータ:R1、R3
Pルータ :R2
CEルータ:R4、R5

PEルータであるR1、R3ではともにVRFとして次のように定義します。

VRF名:VPN
RD:100:100
Import RT:100:100
Export RT:100:100


~設定概要~

各ルータで行われているMPLS-VPNでの通信に関連する設定は次の通りです。

R1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip vrf VPN
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding VPN
 ip address 10.14.14.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
router ospf 14 vrf VPN
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 10.14.14.1 0.0.0.0 area 0
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.0.3 remote-as 100
 neighbor 192.168.0.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf VPN
  redistribute ospf 14 vrf VPN
  no synchronization
 exit-address-family
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
interface Serial1/1
 ip address 192.168.23.2 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip vrf VPN
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding VPN
 ip address 10.35.35.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.23.3 255.255.255.0
 encapsulation ppp
 mpls ip
 no peer neighbor-route
!
router ospf 35 vrf VPN
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 10.35.35.3 0.0.0.0 area 0
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.0.1 remote-as 100
 neighbor 192.168.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 192.168.0.1 activate
  neighbor 192.168.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN
  redistribute ospf 35 vrf VPN
  no synchronization
 exit-address-family
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R4
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 172.16.4.4 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.14.14.4 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 10.14.14.4 0.0.0.0 area 0
 network 172.16.4.4 0.0.0.0 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
 ip address 172.16.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.35.35.5 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 10.35.35.5 0.0.0.0 area 0
 network 172.16.5.5 0.0.0.0 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


~トラブルの症状~

R4、R5でルーティングテーブルを見るとお互いのルートを確認できません。そ
のため、当然、通信が不可能な状態になってしまっています。

R4 show ip route
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#show ip route
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.4.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.14.14.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5 show ip route
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
5#show ip route
~省略~

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.5.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


PEルータであるR1、R3とCEルータであるR4、R5はOSPFでルーティングを行って
います。ネイバーを確認すると、次のように正常にOSPFネイバーを確認できて
います。

R4 show ip ospf neighbor
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R4#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.14.14.1        1   FULL/BDR        00:00:34    10.14.14.1      FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R5 show ip ospf neighbor
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
5#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.35.35.3        1   FULL/BDR        00:00:38    10.35.35.3      FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

そのため、PE-CE間のルーティングには特に問題がないと考えられます。問題
はMPLSバックボーンにある可能性が高いです。そこでMPLSバックボーンを構成
するR1、R2、R3で次のshowコマンドで原因の切り分けを行いました。

R1
show mpls interface
show mpls ldp neighbor
show ip bgp summary
show ip bgp neighbor
show ip bgp vpnv4 all
show ip route vrf VPN

R2
show mpls interface
show mpls ldp neighbor

R3
show mpls interface
show mpls ldp neighbor
show ip bgp summary
show ip bgp neighbor
show ip bgp vpnv4 all
show ip route vrf VPN


R1 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show mpls interface
Interface              IP            Tunnel   Operational
Serial1/0              Yes (ldp)     No       Yes
R1#show mpls ldp neighbor
    Peer LDP Ident: 192.168.0.2:0; Local LDP Ident 192.168.0.1:0
        TCP connection: 192.168.0.2.61071 - 192.168.0.1.646
        State: Oper; Msgs sent/rcvd: 27/27; Downstream
        Up time: 00:16:50
        LDP discovery sources:
          Serial1/0, Src IP addr: 192.168.12.2
        Addresses bound to peer LDP Ident:
          192.168.12.2    192.168.23.2    192.168.0.2
R1#show ip bgp summary
BGP router identifier 192.168.0.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.0.3     4   100      34      34        1    0    0 00:12:16        0
R1#show ip bgp neighbor
BGP neighbor is 192.168.0.3,  remote AS 100, internal link
  BGP version 4, remote router ID 192.168.0.3
  BGP state = Established, up for 00:12:16
  Last read 00:00:16, last write 00:00:16, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    Address family VPNv4 Unicast: received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  4          4
    Notifications:          0          0
    Updates:                6          6
    Keepalives:            24         24
    Route Refresh:          0          0
    Total:                 34         34
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 1, neighbor version 1/0
 Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0

  Connections established 4; dropped 3
  Last reset 00:12:47, due to Neighbor deleted
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 192.168.0.1, Local port: 179
Foreign host: 192.168.0.3, Foreign port: 30997

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x101144):
Timer          Starts    Wakeups            Next
Retrans            15          0             0x0
TimeWait            0          0             0x0
AckHold            14          0             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 3940898747  snduna: 3940899078  sndnxt: 3940899078     sndwnd:  16054
irs:  165713483  rcvnxt:  165713822  rcvwnd:      16046  delrcvwnd:    338

SRTT: 259 ms, RTTO: 579 ms, RTV: 320 ms, KRTT: 0 ms
minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: passive open, nagle, gen tcbs
IP Precedence value : 6

Datagrams (max data segment is 536 bytes):
Rcvd: 30 (out of order: 0), with data: 15, total data bytes: 338
Sent: 15 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 14, total data bytes: 330
R1#show ip bgp vpnv4 all
BGP table version is 19, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf VPN)
*> 10.14.14.0/24    0.0.0.0                  0         32768 ?
*> 172.16.4.0/24    10.14.14.4               2         32768 ?
R1#show ip route vrf VPN

Routing Table: VPN
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
O       172.16.4.0 [110/2] via 10.14.14.4, 00:16:29, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.14.14.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R2#show mpls interface
Interface              IP            Tunnel   Operational
Serial1/0              Yes (ldp)     No       Yes
Serial1/1              Yes (ldp)     No       Yes
R2#show mpls ldp neighbor
    Peer LDP Ident: 192.168.0.3:0; Local LDP Ident 192.168.0.2:0
        TCP connection: 192.168.0.3.51579 - 192.168.0.2.646
        State: Oper; Msgs sent/rcvd: 28/28; Downstream
        Up time: 00:17:46
        LDP discovery sources:
          Serial1/1, Src IP addr: 192.168.23.3
        Addresses bound to peer LDP Ident:
          192.168.0.3     192.168.23.3
    Peer LDP Ident: 192.168.0.1:0; Local LDP Ident 192.168.0.2:0
        TCP connection: 192.168.0.1.646 - 192.168.0.2.61071
        State: Oper; Msgs sent/rcvd: 28/27; Downstream
        Up time: 00:17:33
        LDP discovery sources:
          Serial1/0, Src IP addr: 192.168.12.1
        Addresses bound to peer LDP Ident:
          192.168.0.1     192.168.12.1
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3 showコマンドの結果
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R3#show mpls interface
Interface              IP            Tunnel   Operational
Serial1/0              Yes (ldp)     No       Yes
R3#show mpls ldp neighbor
    Peer LDP Ident: 192.168.0.2:0; Local LDP Ident 192.168.0.3:0
        TCP connection: 192.168.0.2.646 - 192.168.0.3.51579
        State: Oper; Msgs sent/rcvd: 29/28; Downstream
        Up time: 00:18:19
        LDP discovery sources:
          Serial1/0, Src IP addr: 192.168.23.2
        Addresses bound to peer LDP Ident:
          192.168.12.2    192.168.23.2    192.168.0.2
R3#show ip bgp summary
BGP router identifier 192.168.0.3, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.0.1     4   100      35      35        1    0    0 00:13:33        0
R3#show ip bgp neighbor
BGP neighbor is 192.168.0.1,  remote AS 100, internal link
  BGP version 4, remote router ID 192.168.0.1
  BGP state = Established, up for 00:13:33
  Last read 00:00:33, last write 00:00:33, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    Address family VPNv4 Unicast: advertised
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  4          4
    Notifications:          0          0
    Updates:                6          6
    Keepalives:            25         25
    Route Refresh:          0          0
    Total:                 35         35
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 1, neighbor version 1/0
 Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0

 For address family: VPNv4 Unicast
  BGP table version 17, neighbor version 0/0
 Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 1, min 1

  Connections established 4; dropped 3
  Last reset 00:14:02, due to Peer closed the session
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 192.168.0.3, Local port: 30997
Foreign host: 192.168.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x1149C4):
Timer          Starts    Wakeups            Next
Retrans            16          0             0x0
TimeWait            0          0             0x0
AckHold            15         14             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss:  165713483  snduna:  165713841  sndnxt:  165713841     sndwnd:  16027
irs: 3940898747  rcvnxt: 3940899097  rcvwnd:      16035  delrcvwnd:    349

SRTT: 264 ms, RTTO: 545 ms, RTV: 281 ms, KRTT: 0 ms
minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: active open, nagle
IP Precedence value : 6

Datagrams (max data segment is 536 bytes):
Rcvd: 16 (out of order: 0), with data: 15, total data bytes: 349
Sent: 32 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 16, total data bytes: 357
R3#show ip bgp vpnv4 all
BGP table version is 17, local router ID is 192.168.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf VPN)
*> 10.35.35.0/24    0.0.0.0                  0         32768 ?
*> 172.16.5.0/24    10.35.35.5               2         32768 ?
R3#show ip route vrf VPN

Routing Table: VPN
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
O       172.16.5.0 [110/2] via 10.35.35.5, 00:17:46, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.35.35.0 is directly connected, FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R1~R3のshowコマンドによって設定ミスがわかったので修正すると、正常にMPLS-VPN
を通じてR4-R5間の通信ができるようになりました。


~問題~

・PE-CE間のルーティングには問題がないのに、R4-R5間で通信できない理由は
  なんですか?
・MPLS-VPN経由でR4-R5間の通信ができるようにするためには、どのように設
  定を修正すればよいですか?


◆◆◇━━━━……‥‥・・・ ・  ・ ・・・‥‥…━━━━◇◆◆

待望のMPLS-VPNの仕組み解説セミナー、4/25(日)に開催!!
お申込、詳細は以下をご覧ください。

http://www.n-study.com/page/mpls-vpn.html

◆◆◇━━━━……‥‥・・・ ・  ・ ・・・‥‥…━━━━◇◆◆

└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
たまにはシティーホテルでのんびり過ごしたいなぁって言う方は
一休ドットコムの高級ホテル・旅館の予約
≪ http://www.n-study.com/ikkyu/ ≫ 

 ホテル体験レポートもありますよ!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
日経NETWORKは、今年で創刊10周年を迎えますね。
10年前、Geneはネットワーク技術のことをまったく知らない状態でした。2000
年5月の創刊号からずっと日経NETWORKを購読して、最初の一年は日経NETWORK
を繰り返し読んで、それをベースにWebサイトなどを調べて勉強していきました。

          「ネットワーク技術の勉強したい!!!」

という方には、日経NETWORKを購読して「繰り返し読む」ということをオスス
メします。

日経NETWORKの詳細とご購読は下記URLから。
http://www.n-study.com/books/2005/06/network.html
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


「Geneが講師を担当するセミナー情報」
http://www.n-study.com/page/gene.html

Geneが講師を担当するセミナー情報です。幅広い分野のネットワーク技術をわ
かりやすく解説します。ご興味があるセミナーがあれば、ぜひご参加ください。


2010/3/27  CCIE R&S L2 Technology ケーススタディ
ネクストワークス主催(有料)
http://www.nextworks.co.jp/02_seminar/gene01.html
前回 L3 Technologyのケーススタディセミナーを開催しました。

   「CCIE Routing & Switchingラボ試験の他のカテゴリのセミナーも」

という希望をいただいたので、L2 Technologyのケーススタディセミナーを開
催します。
CCIE Routing & Switching ラボ試験で問われるCatalystスイッチ、PPP、Frame Relay
のL2 Technologyについて技術のポイントと実際の問題形式の条件とその解説
を扱います。CCIE Routing & Switchingのラボ試験を勉強する上で、L2 Technology
に関して、「こういうことを学べばいい」ということを明確にしていただけま
す。

2010/4/25 MPLS-VPNの仕組み
オフィス・エヌ・スタディ主催(有料)
http://www.n-study.com/page/mpls-vpn.html
企業の拠点間を接続するサービスとして、IP-VPNが広く利用されています。IP-VPN
はMPLSによって実現されていることが多いです。このセミナーでは、MPLS-VPN
の仕組みを解説し、Ciscoルータでの設定と検証について理解を深めていただ
くことを目的としています。MPLSを勉強するための日本語で読める書籍などは
なかなかありません。MPLS-VPNの仕組みを知りたいという方にオススメです。
また、2009年秋にCCIE Routing & Switchingのラボ試験が改訂されて、MPLS-VPN
も出題範囲に含まれるようになっています。CCIE R&S ラボ試験のために、MPLS-VPN
を勉強したい方にもオススメです。



「Geneにネットワーク技術の講師をやってもらいたい!」という研修担当の方
は↓をご覧ください。

「Geneが御社のネットワーク技術研修の講師を承ります」
http://www.n-study.com/page/gene-instructor.html


また、遠方にお住まいの方から「セミナーに参加できないのでテキストだけで
も購入したい」というお問い合わせをちょくちょくいただくようになりました。
セミナー用のテキストの販売も開始しております。

<教材セットの内容>
・セミナーテキスト
・実機デモ資料
・実機デモ動画解説
・セミナー内容のマインドマップ

ご注文についての詳細は下記リンクをご覧ください。

NE向けセミナー「OSPFの基礎をしっかり身に付ける!」教材セット
http://www.n-study.com/library/2009/05/_011.html

NE向けセミナー「OSPFの高度な機能をばっちり使えるようになる」教材セット
http://www.n-study.com/library/2009/06/neospf.html

ネットワークエンジニア向けセミナー「BGPの基本を学ぶ」教材セット
http://www.n-study.com/library/2009/06/bgp.html

ネットワークエンジニア向けセミナー「高度なBGPの設定」教材セット
http://www.n-study.com/library/2009/06/bgp_1.html

NE向けセミナー「IPマルチキャスト基礎」教材セット
http://www.n-study.com/library/2009/06/neip.html

ネットワークエンジニア向けセミナー「IPマルチキャスト応用」教材セット
http://www.n-study.com/library/2009/06/ip.html

NE向けセミナー「複数のルーティングプロトコルを使いこなす!」教材セット
http://www.n-study.com/library/2009/07/ne.html

NE向けセミナーIPv6ネットワーク構築のためのアドレッシング、
ルーティング、移行技術」教材セット
http://www.n-study.com/library/2009/07/neipv6.html


└─────────────────────────ALL_@bout_Network─┘

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
【新バージョンのCCNAにいち早く対応! 日経BP刊】

Cisco CCNA ICND1テキスト 640-822[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283410/networkstudy-22/ref=nosim/

Cisco CCNA ICND2テキスト 640-816[640-802含む]対応
www.amazon.co.jp/exec/obidos/ASIN/4822283429/networkstudy-22/ref=nosim/

新バージョンに対応した書籍では、一番早いはずです。これは、単に試験に
合格するだけではなくて、自信を持って「ネットワーク技術の基本は完
璧です!!」と言っていただけるようにするためです。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

┌──ALL_@bout_Network────────────────────────┐


  「終わりに」

やりました!バーレーンGP、フェラーリ1-2フィニッシュ!!
個人的には、マッサに勝ってもらいたかったんですが、昨年8月の大ケガから
よく戻ってきてくれたものです。
まぁ、ベッテルのエンジントラブルがなかったら勝てたかどうかは怪しかった
ですけどね。アロンソの方がペースは速くても、抜けそうな雰囲気がなかった
ので。でも、これもレース。

レースが終わっていろんなところで「退屈」なレースと言われています。確か
に退屈だなと思ってしまいました。大きな変動はスタート時とベッテルのトラ
ブルのときぐらいしかなったですからね。スタートして、いったん順位が落ち
着いてしまうと、タイヤを労る優しいドライビングになってしまって、後ろの
クルマがちょっとぐらい速くても、十分に抑えられていましたからね。ピット
も給油がないので、ほとんどタイム差もでないし。
これまで以上に予選の順位が重要で、ポールポジション絶対有利なレースにな
っていきそうです。フェラーリは去年までに比べると、予選の一発勝負でも速
さを発揮できるようになっているみたいなので、活躍してくれるでしょう。個
人的には、フェラーリが速ければ面白いんです。でも、抜きつ抜かれつな本来
の意味で面白いレースはあんまり期待できなさそう・・・

シューマッハは、過剰な期待は酷だと思いつつ、やっぱり期待しすぎてしまっ
ていました。チームメイトに負けるシューマッハはホントに珍しい。ブランク
を取り戻して、少なくともチームメイトには負けないようになって欲しいです。


└─────────────────────────ALL_@bout_Network─┘
                    ★ご購読ありがとうございました★
┌──ALL_@bout_Network────────────────────────┐
|                                                                     |
|WRITTEN BY:Engineer Support info@n-study.com                        |
|WEB PAGE :http://www.n-study.com/                                   |
|                                                                     |
| Copyright(C) 2010 Engineer Support All Rights Reserved             |
|                                                                     |
|このメールマガジンは以下のシステムを利用して発行しています。解除、メ |
|ールアドレス変更は以下のリンクからご自分で行ってください。代行は行い |
|ません。                                                             |
|なお、このメールマガジンの内容について、いかなる損害が生じても補償を |
|することはできません。記載されている情報は、読者の方々の各自のご判断 |
|でご利用ください。                                                   |
|                                                                     |
|◆めろんぱん http://www.melonpan.net/                                |
| http://www.melonpan.net/melonpa/mag-detail.php3?mag_id=000105       |
|◆インターネットの本屋さん『まぐまぐ』 http://www.mag2.com/          |
| http://www.mag2.com/m/0000046467.htm                                |
|◆総合メールマガジンポータルサイト melma! http://www.melma.com       |
| http://www.melma.com/mag/01/m00017301/                              |
|◆カプライト                                                         |
| http://cgi.kapu.biglobe.ne.jp/m/1676.html                           |
|◆E-Magazine                                                         |
| http://www.emaga.com/info/gene.html                                 |
|                                                                     |
└─────────────────────────ALL_@bout_Network─┘

ネットワークのおべんきょしませんか?

発行周期: 週3回程度 最新号:  2019/03/15 部数:  10,621部

ついでに読みたい

ネットワークのおべんきょしませんか?

発行周期:  週3回程度 最新号:  2019/03/15 部数:  10,621部

他のメルマガを読む